网站地图
  • 股票配资
  • 期货配资
  • 外汇配资
  • 股票行情
  • 正规配资平台
  • 配资资讯
  • 配资技巧
  • 配资公司
  • 投资理财
  • 用户须知
  • 「指数」通达信主力骗钱点,底部选股,优化MACD主图指标

    文章来源:CB财经网 发布时间: 2020-03-19 09:43:41作者:纪泓阅读()
    主力骗钱点:

    {主力骗钱点}
    N:=24;
    VAR1:= EMA(EMA(CLOSE,13),13);
    控盘指数: (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000,POINTDOT,COLORFFCCCC;
    STICKLINE(控盘指数<0,控盘指数,0,2,0),COLORGRAY;
    无庄控盘: 控盘指数<0,LINETHICK0,COLORGRAY;
    STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>0 AND 控盘指数<3,控盘指数,0,2,1),COLORRED;
    STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>0 AND 控盘指数>3,控盘指数,0,2,1),COLORRED;
    STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>3,控盘指数,3,4,1),COLORFF00FF;
    主力控盘: 控盘指数>REF(控盘指数,1) AND 控盘指数>0,LINETHICK0,COLORRED;
    STICKLINE(控盘指数<REF(控盘指数,1) AND 控盘指数>0,控盘指数,0,2,0),COLOR00FF00;
    控盘减弱: 控盘指数<REF(控盘指数,1) AND 控盘指数>0,LINETHICK0,COLOR00FF00;
    VARA:= EMA(0.667*REF(控盘指数,1)+0.333*控盘指数,2);
    STICKLINE(控盘指数>VARA,控盘指数,VARA,2,0),COLORRED;
    B2:= 控盘指数>VARA;
    准备: B2>REF(B2,1) AND 控盘指数<(-2),COLORYELLOW;
    DRAWTEXT(准备,3,'准备'),COLORYELLOW;
    B1:= (控盘指数>REF(控盘指数,1) AND 控盘指数>0)=1;
    开始控盘: B1>REF(B1,1),COLORMAGENTA,LINETHICK3;
    A:=(3*C+L+O+H)/6;
    X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
    14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
    +7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
    REF(A,20))/210;
    MTM:=C-REF(C,1);
    DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
    CB:=EMA(X,13);
    买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
    DRAWICON(FILTER(买=1,5),L*0.11,1);
    DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,COLORWHITE,LINETHICK1;
    DEA:EMA(DIFF,9),COLORYELLOW,LINETHICK1;
    MACD:2*(DIFF-DEA), COLORSTICK;
    MACD1:=2*(DIFF-DEA),COLORRED,NODRAW;
    MACD2:=EMA(MACD1,3),COLORCYAN,NODRAW;
    STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
    STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLORYELLOW;
    STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORGREEN;
    S1:=MACD<0;
    S2:= (MACD>=0);
    S3:=BARSLAST(CROSS(DIFF,DEA));
    S4:=REF(S3,S3+1);
    S5:=DEA>REF(DEA,S4);
    S6:=DEA;
    上成立:=CROSS(DIFF,DEA) AND S5;
    下成立:=CROSS(DIFF,DEA) AND S6;
    L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
    L2:=EMA(L1,9);
    L3:=BARSLAST(CROSS(L1,L2));
    L4:=REF(L3,L3+1);
    L5:=L2;
    变盘:CROSS(L1,L2) AND L5,NODRAW,COLORD6FF9C;
    STICKLINE(变盘,5,0,0,1),COLORD6FF9C;
    LS:=IF(DIFF>DEA AND DIFF>0,1,0);
    加速上扬:IF(REF(LS=0,1) AND LS=1,0.1,0);
    XG1:CROSS(MACD1,MACD2) AND MACD1<0,NODRAW;
    XG2:CROSS(DIFF,DEA),NODRAW;
    M1:=MACD>REF(MACD,1) AND DIFF<DEA;
    绿柱短了:M1 AND COUNT(M1,10)=1 AND C>MA(C,55) AND COUNT(MACD<0,5)>=5,NODRAW;
    DRAWTEXT(绿柱短了,MACD,'买点来了');
    DIFL:=EMA(V,12)-EMA(V,26);
    DIF:=EMA(C,12)-EMA(C,26);
    BL:=DIFL>REF(DIFL,1) AND DIF<REF(DIF,1);
    四天: REF(BL,3)=1 AND REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
    三天:REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
    DRAWTEXT(FILTER(CROSS(ROC,0),6),L-2.25,'骗线拐点'),COLORWHITE;



    底部选股:

     {底部选股}

     
    A:=COUNT("MACD.MACD">0,14)=14;
    DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIFF,9);
    MACD:=(DIFF-DEA)*2;
    零上:=A AND  DIFF>0 AND DEA>0 AND  MACD>0;
    筹码:=LOW*0.95<COST(10) AND CLOSE*1.01>COST(50) AND H*1.15>COST(80);
    MA6:=MA(C,6);
    MA18:=MA(C,18);
    买进价:=((C-REF(MA6,1))/6+MA6)*1.004;
    买进条件:=CROSS(C,买进价) AND 买进价>REF(买进价,1);
    上轨:=(1+6/100)*MA(CLOSE,25);
    交叉:=CROSS(C,上轨);
    交筹:=CROSS(MA(C,3),COST(50));
    白金:零上 AND 筹码 AND 买进条件 AND V>1.7*REF(V,1);
    {前:=REF(C,1)<C AND  COUNT(白金,3)>=1;}
    新高:=HHV(CLOSE,30)=CLOSE;
    买:筹码 AND  V>1.7*REF(V,1) AND (交叉 OR 交筹) AND 新高;




    优化MACD主图(CB财经:股票学院 http://www.lagzc.com):

    优化MACD主图,没未来函数

    优化MACD

    用法自己体会
     

    {MACD主图}

    ZIF:=EMA(C,12)-EMA(C,26);

    ZEA:=EMA(ZIF,9);

    ZBC:=2*(ZIF-ZEA);

    ZJS:=1.25*ZIF-0.25*ZEA;

    ZXH:=(ZJS*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORWHITE;

    ZPH:=(ZIF*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORYELLOW;

    ZQS:=(ZEA*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORCYAN;

    ZNX:=(ZXH+ZQS)/2,COLORMAGENTA;

    信号:ZXH,COLORFFFFFF,LINETHICK1;

    平滑:ZPH,COLOR00FFFF,LINETHICK1;

    牛熊:ZNX,COLORFF00FF,COLORGREEN,LINETHICK2;

    IF(牛熊>=REF(牛熊,1),牛熊,DRAWNULL),COLOREE00EE,LINETHICK2;

    趋势:ZQS,COLORFFFF00,LINETHICK1;

    DRAWKLINE(H,O,L,C);

    M3A:=MA(CLOSE,3);

    M13:=MA(CLOSE,13);

    M34:=MA(CLOSE,34);

    {生命线:SMA(C,21,1),COLORGREEN,LINETHICK1;}

    {魔鬼线:MA(CLOSE,321),LINETHICK2,COLORWHITE;}

    AAAAA:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));

    BBBBB:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);

    分水岭:=IF(MA(CLOSE,17)<BBBBB,BBBBB,MA(CLOSE,17)),COLORYELLOW,LINETHICK2;

    操作线:=分水岭-(EMA(C,6)-分水岭),COLORF0F000,LINETHICK1;

    STICKLINE(M3A>=M13 AND M34>=REF(M34,1) ,H ,L ,0 ,0 ),COLORRED; 

    {STICKLINE(M3A>=M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,3 ,0 ),COLORRED; 

    STICKLINE(M3A>=M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,3 ,1 ),COLORRED;}

    STICKLINE(M3A<M13 AND M34>=REF(M34,1) ,H ,L ,0 ,0 ),COLORFFBB00; 

    STICKLINE(M3A<M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,3 ,0 ),COLORFFBB00; 

    STICKLINE(M3A<M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,3 ,1 ),COLORFFBB00; 

    STICKLINE(M3A<M13 AND M34<REF(M34,1) ,H ,L ,0 ,0 ),COLORFF0000; 

    STICKLINE(M3A<M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,3 ,0 ),COLORFF0000; 

    STICKLINE(M3A<M13 AND M34<REF(M34,1) AND C<O ,O ,C ,3 ,1 ),COLORFF0000; 

    STICKLINE(M3A>=M13 AND M34<REF(M34,1) ,H ,L ,0 ,0 ),COLORFF00FF; 

    STICKLINE(M3A>=M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,3 ,0 ),COLORFF00FF; 

    STICKLINE(M3A>=M13 AND M34<REF(M34,1) AND C<O ,O ,C ,3 ,1 ),COLORFF00FF; 

    X00:=(C+H+L)/3;

    X01:=IFF(CURRBARSCOUNT>1,XMA(X00,3),0.740524*X00+0.35541*REF(X00,1)-0.0316004*REF(X00,2)-0.0374119*REF(X00,3)-0.0218805*REF(X00,4)-0.00386503*REF(X00,5)-0.00102704*REF(X00,6)-0.000131447*REF(X00,7)-0.0000169351*REF(X00,8));

    X02:=IFF(CURRBARSCOUNT>1,XMA(X01,3),0.740524*X01+0.35541*REF(X01,1)-0.0316004*REF(X01,2)-0.0374119*REF(X01,3)-0.0218805*REF(X01,4)-0.00386503*REF(X01,5)-0.00102704*REF(X01,6)-0.000131447*REF(X01,7)-0.0000169351*REF(X01,8));

    X03:=IFF(CURRBARSCOUNT>1,XMA(X02,3),0.740524*X02+0.35541*REF(X02,1)-0.0316004*REF(X02,2)-0.0374119*REF(X02,3)-0.0218805*REF(X02,4)-0.00386503*REF(X02,5)-0.00102704*REF(X02,6)-0.000131447*REF(X02,7)-0.0000169351*REF(X02,8));

    X04:=IFF(CURRBARSCOUNT>1,XMA(X03,3),0.740524*X03+0.35541*REF(X03,1)-0.0316004*REF(X03,2)-0.0374119*REF(X03,3)-0.0218805*REF(X03,4)-0.00386503*REF(X03,5)-0.00102704*REF(X03,6)-0.000131447*REF(X03,7)-0.0000169351*REF(X03,8));

    X05:=IFF(CURRBARSCOUNT>1,XMA(X04,3),0.740524*X04+0.35541*REF(X04,1)-0.0316004*REF(X04,2)-0.0374119*REF(X04,3)-0.0218805*REF(X04,4)-0.00386503*REF(X04,5)-0.00102704*REF(X04,6)-0.000131447*REF(X04,7)-0.0000169351*REF(X04,8));

    X06:=IFF(CURRBARSCOUNT>1,XMA(X05,3),0.740524*X05+0.35541*REF(X05,1)-0.0316004*REF(X05,2)-0.0374119*REF(X05,3)-0.0218805*REF(X05,4)-0.00386503*REF(X05,5)-0.00102704*REF(X05,6)-0.000131447*REF(X05,7)-0.0000169351*REF(X05,8));

    X07:=IFF(CURRBARSCOUNT>1,XMA(X06,3),0.740524*X06+0.35541*REF(X06,1)-0.0316004*REF(X06,2)-0.0374119*REF(X06,3)-0.0218805*REF(X06,4)-0.00386503*REF(X06,5)-0.00102704*REF(X06,6)-0.000131447*REF(X06,7)-0.0000169351*REF(X06,8));

    X08:=IFF(CURRBARSCOUNT>1,XMA(X07,3),0.740524*X07+0.35541*REF(X07,1)-0.0316004*REF(X07,2)-0.0374119*REF(X07,3)-0.0218805*REF(X07,4)-0.00386503*REF(X07,5)-0.00102704*REF(X07,6)-0.000131447*REF(X07,7)-0.0000169351*REF(X07,8));

    X09:=IFF(CURRBARSCOUNT>1,XMA(X08,3),0.740524*X08+0.35541*REF(X08,1)-0.0316004*REF(X08,2)-0.0374119*REF(X08,3)-0.0218805*REF(X08,4)-0.00386503*REF(X08,5)-0.00102704*REF(X08,6)-0.000131447*REF(X08,7)-0.0000169351*REF(X08,8));

    X10:=IFF(CURRBARSCOUNT>1,XMA(X09,3),0.740524*X09+0.35541*REF(X09,1)-0.0316004*REF(X09,2)-0.0374119*REF(X09,3)-0.0218805*REF(X09,4)-0.00386503*REF(X09,5)-0.00102704*REF(X09,6)-0.000131447*REF(X09,7)-0.0000169351*REF(X09,8));

    X11:=IFF(CURRBARSCOUNT>1,XMA(X10,3),0.740524*X10+0.35541*REF(X10,1)-0.0316004*REF(X10,2)-0.0374119*REF(X10,3)-0.0218805*REF(X10,4)-0.00386503*REF(X10,5)-0.00102704*REF(X10,6)-0.000131447*REF(X10,7)-0.0000169351*REF(X10,8));

    X12:=IFF(CURRBARSCOUNT>1,XMA(X11,3),0.740524*X11+0.35541*REF(X11,1)-0.0316004*REF(X11,2)-0.0374119*REF(X11,3)-0.0218805*REF(X11,4)-0.00386503*REF(X11,5)-0.00102704*REF(X11,6)-0.000131447*REF(X11,7)-0.0000169351*REF(X11,8));

    X13:=IFF(CURRBARSCOUNT>1,XMA(X12,3),0.740524*X12+0.35541*REF(X12,1)-0.0316004*REF(X12,2)-0.0374119*REF(X12,3)-0.0218805*REF(X12,4)-0.00386503*REF(X12,5)-0.00102704*REF(X12,6)-0.000131447*REF(X12,7)-0.0000169351*REF(X12,8));

    X14:=IFF(CURRBARSCOUNT>1,XMA(X13,3),0.740524*X13+0.35541*REF(X13,1)-0.0316004*REF(X13,2)-0.0374119*REF(X13,3)-0.0218805*REF(X13,4)-0.00386503*REF(X13,5)-0.00102704*REF(X13,6)-0.000131447*REF(X13,7)-0.0000169351*REF(X13,8));

    X15:=IFF(CURRBARSCOUNT>1,XMA(X14,3),0.740524*X14+0.35541*REF(X14,1)-0.0316004*REF(X14,2)-0.0374119*REF(X14,3)-0.0218805*REF(X14,4)-0.00386503*REF(X14,5)-0.00102704*REF(X14,6)-0.000131447*REF(X14,7)-0.0000169351*REF(X14,8));

    X16:=IFF(CURRBARSCOUNT>1,XMA(X15,3),0.740524*X15+0.35541*REF(X15,1)-0.0316004*REF(X15,2)-0.0374119*REF(X15,3)-0.0218805*REF(X15,4)-0.00386503*REF(X15,5)-0.00102704*REF(X15,6)-0.000131447*REF(X15,7)-0.0000169351*REF(X15,8));

    X17:=IFF(CURRBARSCOUNT>1,XMA(X16,3),0.740524*X16+0.35541*REF(X16,1)-0.0316004*REF(X16,2)-0.0374119*REF(X16,3)-0.0218805*REF(X16,4)-0.00386503*REF(X16,5)-0.00102704*REF(X16,6)-0.000131447*REF(X16,7)-0.0000169351*REF(X16,8));

    X18:=IFF(CURRBARSCOUNT>1,XMA(X17,3),0.740524*X17+0.35541*REF(X17,1)-0.0316004*REF(X17,2)-0.0374119*REF(X17,3)-0.0218805*REF(X17,4)-0.00386503*REF(X17,5)-0.00102704*REF(X17,6)-0.000131447*REF(X17,7)-0.0000169351*REF(X17,8));

    X19:=IFF(CURRBARSCOUNT>1,XMA(X18,3),0.740524*X18+0.35541*REF(X18,1)-0.0316004*REF(X18,2)-0.0374119*REF(X18,3)-0.0218805*REF(X18,4)-0.00386503*REF(X18,5)-0.00102704*REF(X18,6)-0.000131447*REF(X18,7)-0.0000169351*REF(X18,8));

    X20:=IFF(CURRBARSCOUNT>1,XMA(X19,3),0.740524*X19+0.35541*REF(X19,1)-0.0316004*REF(X19,2)-0.0374119*REF(X19,3)-0.0218805*REF(X19,4)-0.00386503*REF(X19,5)-0.00102704*REF(X19,6)-0.000131447*REF(X19,7)-0.0000169351*REF(X19,8));

    X21:=IFF(CURRBARSCOUNT>1,XMA(X20,3),0.740524*X20+0.35541*REF(X20,1)-0.0316004*REF(X20,2)-0.0374119*REF(X20,3)-0.0218805*REF(X20,4)-0.00386503*REF(X20,5)-0.00102704*REF(X20,6)-0.000131447*REF(X20,7)-0.0000169351*REF(X20,8));

    X22:=IFF(CURRBARSCOUNT>1,XMA(X21,3),0.740524*X21+0.35541*REF(X21,1)-0.0316004*REF(X21,2)-0.0374119*REF(X21,3)-0.0218805*REF(X21,4)-0.00386503*REF(X21,5)-0.00102704*REF(X21,6)-0.000131447*REF(X21,7)-0.0000169351*REF(X21,8));

    X23:=IFF(CURRBARSCOUNT>1,XMA(X22,3),0.740524*X22+0.35541*REF(X22,1)-0.0316004*REF(X22,2)-0.0374119*REF(X22,3)-0.0218805*REF(X22,4)-0.00386503*REF(X22,5)-0.00102704*REF(X22,6)-0.000131447*REF(X22,7)-0.0000169351*REF(X22,8));

    X24:=IFF(CURRBARSCOUNT>1,XMA(X23,3),0.740524*X23+0.35541*REF(X23,1)-0.0316004*REF(X23,2)-0.0374119*REF(X23,3)-0.0218805*REF(X23,4)-0.00386503*REF(X23,5)-0.00102704*REF(X23,6)-0.000131447*REF(X23,7)-0.0000169351*REF(X23,8));

    X25:=IFF(CURRBARSCOUNT>1,XMA(X24,3),0.740524*X24+0.35541*REF(X24,1)-0.0316004*REF(X24,2)-0.0374119*REF(X24,3)-0.0218805*REF(X24,4)-0.00386503*REF(X24,5)-0.00102704*REF(X24,6)-0.000131447*REF(X24,7)-0.0000169351*REF(X24,8));

    X26:=IFF(CURRBARSCOUNT>1,XMA(X25,3),0.740524*X25+0.35541*REF(X25,1)-0.0316004*REF(X25,2)-0.0374119*REF(X25,3)-0.0218805*REF(X25,4)-0.00386503*REF(X25,5)-0.00102704*REF(X25,6)-0.000131447*REF(X25,7)-0.0000169351*REF(X25,8));

    X27:=IFF(CURRBARSCOUNT>1,XMA(X26,3),0.740524*X26+0.35541*REF(X26,1)-0.0316004*REF(X26,2)-0.0374119*REF(X26,3)-0.0218805*REF(X26,4)-0.00386503*REF(X26,5)-0.00102704*REF(X26,6)-0.000131447*REF(X26,7)-0.0000169351*REF(X26,8));

    X28:=IFF(CURRBARSCOUNT>1,XMA(X27,3),0.740524*X27+0.35541*REF(X27,1)-0.0316004*REF(X27,2)-0.0374119*REF(X27,3)-0.0218805*REF(X27,4)-0.00386503*REF(X27,5)-0.00102704*REF(X27,6)-0.000131447*REF(X27,7)-0.0000169351*REF(X27,8));

    X29:=IFF(CURRBARSCOUNT>1,XMA(X28,3),0.740524*X28+0.35541*REF(X28,1)-0.0316004*REF(X28,2)-0.0374119*REF(X28,3)-0.0218805*REF(X28,4)-0.00386503*REF(X28,5)-0.00102704*REF(X28,6)-0.000131447*REF(X28,7)-0.0000169351*REF(X28,8));

    X30:=IFF(CURRBARSCOUNT>1,XMA(X29,3),0.740524*X29+0.35541*REF(X29,1)-0.0316004*REF(X29,2)-0.0374119*REF(X29,3)-0.0218805*REF(X29,4)-0.00386503*REF(X29,5)-0.00102704*REF(X29,6)-0.000131447*REF(X29,7)-0.0000169351*REF(X29,8));

    X31:=IFF(CURRBARSCOUNT>1,XMA(X30,3),0.740524*X30+0.35541*REF(X30,1)-0.0316004*REF(X30,2)-0.0374119*REF(X30,3)-0.0218805*REF(X30,4)-0.00386503*REF(X30,5)-0.00102704*REF(X30,6)-0.000131447*REF(X30,7)-0.0000169351*REF(X30,8));

    X32:=IFF(CURRBARSCOUNT>1,XMA(X31,3),0.740524*X31+0.35541*REF(X31,1)-0.0316004*REF(X31,2)-0.0374119*REF(X31,3)-0.0218805*REF(X31,4)-0.00386503*REF(X31,5)-0.00102704*REF(X31,6)-0.000131447*REF(X31,7)-0.0000169351*REF(X31,8));

    X33:=IFF(CURRBARSCOUNT>1,XMA(X32,3),0.740524*X32+0.35541*REF(X32,1)-0.0316004*REF(X32,2)-0.0374119*REF(X32,3)-0.0218805*REF(X32,4)-0.00386503*REF(X32,5)-0.00102704*REF(X32,6)-0.000131447*REF(X32,7)-0.0000169351*REF(X32,8));

    X34:=IFF(CURRBARSCOUNT>1,XMA(X33,3),0.740524*X33+0.35541*REF(X33,1)-0.0316004*REF(X33,2)-0.0374119*REF(X33,3)-0.0218805*REF(X33,4)-0.00386503*REF(X33,5)-0.00102704*REF(X33,6)-0.000131447*REF(X33,7)-0.0000169351*REF(X33,8));

    X35:=IFF(CURRBARSCOUNT>1,XMA(X34,3),0.740524*X34+0.35541*REF(X34,1)-0.0316004*REF(X34,2)-0.0374119*REF(X34,3)-0.0218805*REF(X34,4)-0.00386503*REF(X34,5)-0.00102704*REF(X34,6)-0.000131447*REF(X34,7)-0.0000169351*REF(X34,8));

    X36:=IFF(CURRBARSCOUNT>1,XMA(X35,3),0.740524*X35+0.35541*REF(X35,1)-0.0316004*REF(X35,2)-0.0374119*REF(X35,3)-0.0218805*REF(X35,4)-0.00386503*REF(X35,5)-0.00102704*REF(X35,6)-0.000131447*REF(X35,7)-0.0000169351*REF(X35,8));

    X37:=IFF(CURRBARSCOUNT>1,XMA(X36,3),0.740524*X36+0.35541*REF(X36,1)-0.0316004*REF(X36,2)-0.0374119*REF(X36,3)-0.0218805*REF(X36,4)-0.00386503*REF(X36,5)-0.00102704*REF(X36,6)-0.000131447*REF(X36,7)-0.0000169351*REF(X36,8));

    X38:=IFF(CURRBARSCOUNT>1,XMA(X37,3),0.740524*X37+0.35541*REF(X37,1)-0.0316004*REF(X37,2)-0.0374119*REF(X37,3)-0.0218805*REF(X37,4)-0.00386503*REF(X37,5)-0.00102704*REF(X37,6)-0.000131447*REF(X37,7)-0.0000169351*REF(X37,8));

    X39:=IFF(CURRBARSCOUNT>1,XMA(X38,3),0.740524*X38+0.35541*REF(X38,1)-0.0316004*REF(X38,2)-0.0374119*REF(X38,3)-0.0218805*REF(X38,4)-0.00386503*REF(X38,5)-0.00102704*REF(X38,6)-0.000131447*REF(X38,7)-0.0000169351*REF(X38,8));

    X40:=IFF(CURRBARSCOUNT>1,XMA(X39,3),0.740524*X39+0.35541*REF(X39,1)-0.0316004*REF(X39,2)-0.0374119*REF(X39,3)-0.0218805*REF(X39,4)-0.00386503*REF(X39,5)-0.00102704*REF(X39,6)-0.000131447*REF(X39,7)-0.0000169351*REF(X39,8));

    X41:=IFF(CURRBARSCOUNT>1,XMA(X40,3),0.740524*X40+0.35541*REF(X40,1)-0.0316004*REF(X40,2)-0.0374119*REF(X40,3)-0.0218805*REF(X40,4)-0.00386503*REF(X40,5)-0.00102704*REF(X40,6)-0.000131447*REF(X40,7)-0.0000169351*REF(X40,8));

    X42:=IFF(CURRBARSCOUNT>1,XMA(X41,3),0.740524*X41+0.35541*REF(X41,1)-0.0316004*REF(X41,2)-0.0374119*REF(X41,3)-0.0218805*REF(X41,4)-0.00386503*REF(X41,5)-0.00102704*REF(X41,6)-0.000131447*REF(X41,7)-0.0000169351*REF(X41,8));

    X43:=IFF(CURRBARSCOUNT>1,XMA(X42,3),0.740524*X42+0.35541*REF(X42,1)-0.0316004*REF(X42,2)-0.0374119*REF(X42,3)-0.0218805*REF(X42,4)-0.00386503*REF(X42,5)-0.00102704*REF(X42,6)-0.000131447*REF(X42,7)-0.0000169351*REF(X42,8));

    X44:=IFF(CURRBARSCOUNT>1,XMA(X43,3),0.740524*X43+0.35541*REF(X43,1)-0.0316004*REF(X43,2)-0.0374119*REF(X43,3)-0.0218805*REF(X43,4)-0.00386503*REF(X43,5)-0.00102704*REF(X43,6)-0.000131447*REF(X43,7)-0.0000169351*REF(X43,8));

    X45:=IFF(CURRBARSCOUNT>1,XMA(X44,3),0.740524*X44+0.35541*REF(X44,1)-0.0316004*REF(X44,2)-0.0374119*REF(X44,3)-0.0218805*REF(X44,4)-0.00386503*REF(X44,5)-0.00102704*REF(X44,6)-0.000131447*REF(X44,7)-0.0000169351*REF(X44,8));

    X46:=IFF(CURRBARSCOUNT>1,XMA(X45,3),0.740524*X45+0.35541*REF(X45,1)-0.0316004*REF(X45,2)-0.0374119*REF(X45,3)-0.0218805*REF(X45,4)-0.00386503*REF(X45,5)-0.00102704*REF(X45,6)-0.000131447*REF(X45,7)-0.0000169351*REF(X45,8));

    X47:=IFF(CURRBARSCOUNT>1,XMA(X46,3),0.740524*X46+0.35541*REF(X46,1)-0.0316004*REF(X46,2)-0.0374119*REF(X46,3)-0.0218805*REF(X46,4)-0.00386503*REF(X46,5)-0.00102704*REF(X46,6)-0.000131447*REF(X46,7)-0.0000169351*REF(X46,8));

    X48:=IFF(CURRBARSCOUNT>1,XMA(X47,3),0.740524*X47+0.35541*REF(X47,1)-0.0316004*REF(X47,2)-0.0374119*REF(X47,3)-0.0218805*REF(X47,4)-0.00386503*REF(X47,5)-0.00102704*REF(X47,6)-0.000131447*REF(X47,7)-0.0000169351*REF(X47,8));

    X49:=IFF(CURRBARSCOUNT>1,XMA(X48,3),0.740524*X48+0.35541*REF(X48,1)-0.0316004*REF(X48,2)-0.0374119*REF(X48,3)-0.0218805*REF(X48,4)-0.00386503*REF(X48,5)-0.00102704*REF(X48,6)-0.000131447*REF(X48,7)-0.0000169351*REF(X48,8));

    X50:=IFF(CURRBARSCOUNT>1,XMA(X49,3),0.740524*X49+0.35541*REF(X49,1)-0.0316004*REF(X49,2)-0.0374119*REF(X49,3)-0.0218805*REF(X49,4)-0.00386503*REF(X49,5)-0.00102704*REF(X49,6)-0.000131447*REF(X49,7)-0.0000169351*REF(X49,8));

    X51:=IFF(CURRBARSCOUNT>1,XMA(X50,3),0.740524*X50+0.35541*REF(X50,1)-0.0316004*REF(X50,2)-0.0374119*REF(X50,3)-0.0218805*REF(X50,4)-0.00386503*REF(X50,5)-0.00102704*REF(X50,6)-0.000131447*REF(X50,7)-0.0000169351*REF(X50,8));

    X52:=IFF(CURRBARSCOUNT>1,XMA(X51,3),0.740524*X51+0.35541*REF(X51,1)-0.0316004*REF(X51,2)-0.0374119*REF(X51,3)-0.0218805*REF(X51,4)-0.00386503*REF(X51,5)-0.00102704*REF(X51,6)-0.000131447*REF(X51,7)-0.0000169351*REF(X51,8));

    X53:=IFF(CURRBARSCOUNT>1,XMA(X52,3),0.740524*X52+0.35541*REF(X52,1)-0.0316004*REF(X52,2)-0.0374119*REF(X52,3)-0.0218805*REF(X52,4)-0.00386503*REF(X52,5)-0.00102704*REF(X52,6)-0.000131447*REF(X52,7)-0.0000169351*REF(X52,8));

    X54:=IFF(CURRBARSCOUNT>1,XMA(X53,3),0.740524*X53+0.35541*REF(X53,1)-0.0316004*REF(X53,2)-0.0374119*REF(X53,3)-0.0218805*REF(X53,4)-0.00386503*REF(X53,5)-0.00102704*REF(X53,6)-0.000131447*REF(X53,7)-0.0000169351*REF(X53,8));

    X55:=IFF(CURRBARSCOUNT>1,XMA(X54,3),0.740524*X54+0.35541*REF(X54,1)-0.0316004*REF(X54,2)-0.0374119*REF(X54,3)-0.0218805*REF(X54,4)-0.00386503*REF(X54,5)-0.00102704*REF(X54,6)-0.000131447*REF(X54,7)-0.0000169351*REF(X54,8));

    X56:=IFF(CURRBARSCOUNT>1,XMA(X55,3),0.740524*X55+0.35541*REF(X55,1)-0.0316004*REF(X55,2)-0.0374119*REF(X55,3)-0.0218805*REF(X55,4)-0.00386503*REF(X55,5)-0.00102704*REF(X55,6)-0.000131447*REF(X55,7)-0.0000169351*REF(X55,8));

    X57:=IFF(CURRBARSCOUNT>1,XMA(X56,3),0.740524*X56+0.35541*REF(X56,1)-0.0316004*REF(X56,2)-0.0374119*REF(X56,3)-0.0218805*REF(X56,4)-0.00386503*REF(X56,5)-0.00102704*REF(X56,6)-0.000131447*REF(X56,7)-0.0000169351*REF(X56,8));

    X58:=IFF(CURRBARSCOUNT>1,XMA(X57,3),0.740524*X57+0.35541*REF(X57,1)-0.0316004*REF(X57,2)-0.0374119*REF(X57,3)-0.0218805*REF(X57,4)-0.00386503*REF(X57,5)-0.00102704*REF(X57,6)-0.000131447*REF(X57,7)-0.0000169351*REF(X57,8));

    X59:=IFF(CURRBARSCOUNT>1,XMA(X58,3),0.740524*X58+0.35541*REF(X58,1)-0.0316004*REF(X58,2)-0.0374119*REF(X58,3)-0.0218805*REF(X58,4)-0.00386503*REF(X58,5)-0.00102704*REF(X58,6)-0.000131447*REF(X58,7)-0.0000169351*REF(X58,8));

    X60:=IFF(CURRBARSCOUNT>1,XMA(X59,3),0.740524*X59+0.35541*REF(X59,1)-0.0316004*REF(X59,2)-0.0374119*REF(X59,3)-0.0218805*REF(X59,4)-0.00386503*REF(X59,5)-0.00102704*REF(X59,6)-0.000131447*REF(X59,7)-0.0000169351*REF(X59,8));

    X61:=IFF(CURRBARSCOUNT>1,XMA(X60,3),0.740524*X60+0.35541*REF(X60,1)-0.0316004*REF(X60,2)-0.0374119*REF(X60,3)-0.0218805*REF(X60,4)-0.00386503*REF(X60,5)-0.00102704*REF(X60,6)-0.000131447*REF(X60,7)-0.0000169351*REF(X60,8));

    X62:=IFF(CURRBARSCOUNT>1,XMA(X61,3),0.740524*X61+0.35541*REF(X61,1)-0.0316004*REF(X61,2)-0.0374119*REF(X61,3)-0.0218805*REF(X61,4)-0.00386503*REF(X61,5)-0.00102704*REF(X61,6)-0.000131447*REF(X61,7)-0.0000169351*REF(X61,8));

    X63:=IFF(CURRBARSCOUNT>1,XMA(X62,3),0.740524*X62+0.35541*REF(X62,1)-0.0316004*REF(X62,2)-0.0374119*REF(X62,3)-0.0218805*REF(X62,4)-0.00386503*REF(X62,5)-0.00102704*REF(X62,6)-0.000131447*REF(X62,7)-0.0000169351*REF(X62,8));

    X64:=IFF(CURRBARSCOUNT>1,XMA(X63,3),0.740524*X63+0.35541*REF(X63,1)-0.0316004*REF(X63,2)-0.0374119*REF(X63,3)-0.0218805*REF(X63,4)-0.00386503*REF(X63,5)-0.00102704*REF(X63,6)-0.000131447*REF(X63,7)-0.0000169351*REF(X63,8));

    X65:=IFF(CURRBARSCOUNT>1,XMA(X64,3),0.740524*X64+0.35541*REF(X64,1)-0.0316004*REF(X64,2)-0.0374119*REF(X64,3)-0.0218805*REF(X64,4)-0.00386503*REF(X64,5)-0.00102704*REF(X64,6)-0.000131447*REF(X64,7)-0.0000169351*REF(X64,8));

    X66:=IFF(CURRBARSCOUNT>1,XMA(X65,3),0.740524*X65+0.35541*REF(X65,1)-0.0316004*REF(X65,2)-0.0374119*REF(X65,3)-0.0218805*REF(X65,4)-0.00386503*REF(X65,5)-0.00102704*REF(X65,6)-0.000131447*REF(X65,7)-0.0000169351*REF(X65,8));

    X67:=IFF(CURRBARSCOUNT>1,XMA(X66,3),0.740524*X66+0.35541*REF(X66,1)-0.0316004*REF(X66,2)-0.0374119*REF(X66,3)-0.0218805*REF(X66,4)-0.00386503*REF(X66,5)-0.00102704*REF(X66,6)-0.000131447*REF(X66,7)-0.0000169351*REF(X66,8));

    X68:=IFF(CURRBARSCOUNT>1,XMA(X67,3),0.740524*X67+0.35541*REF(X67,1)-0.0316004*REF(X67,2)-0.0374119*REF(X67,3)-0.0218805*REF(X67,4)-0.00386503*REF(X67,5)-0.00102704*REF(X67,6)-0.000131447*REF(X67,7)-0.0000169351*REF(X67,8));

    X69:=IFF(CURRBARSCOUNT>1,XMA(X68,3),0.740524*X68+0.35541*REF(X68,1)-0.0316004*REF(X68,2)-0.0374119*REF(X68,3)-0.0218805*REF(X68,4)-0.00386503*REF(X68,5)-0.00102704*REF(X68,6)-0.000131447*REF(X68,7)-0.0000169351*REF(X68,8));

    X70:=IFF(CURRBARSCOUNT>1,XMA(X69,3),0.740524*X69+0.35541*REF(X69,1)-0.0316004*REF(X69,2)-0.0374119*REF(X69,3)-0.0218805*REF(X69,4)-0.00386503*REF(X69,5)-0.00102704*REF(X69,6)-0.000131447*REF(X69,7)-0.0000169351*REF(X69,8));

    X71:=IFF(CURRBARSCOUNT>1,XMA(X70,3),0.740524*X70+0.35541*REF(X70,1)-0.0316004*REF(X70,2)-0.0374119*REF(X70,3)-0.0218805*REF(X70,4)-0.00386503*REF(X70,5)-0.00102704*REF(X70,6)-0.000131447*REF(X70,7)-0.0000169351*REF(X70,8));

    X72:=IFF(CURRBARSCOUNT>1,XMA(X71,3),0.740524*X71+0.35541*REF(X71,1)-0.0316004*REF(X71,2)-0.0374119*REF(X71,3)-0.0218805*REF(X71,4)-0.00386503*REF(X71,5)-0.00102704*REF(X71,6)-0.000131447*REF(X71,7)-0.0000169351*REF(X71,8));

    X73:=IFF(CURRBARSCOUNT>1,XMA(X72,3),0.740524*X72+0.35541*REF(X72,1)-0.0316004*REF(X72,2)-0.0374119*REF(X72,3)-0.0218805*REF(X72,4)-0.00386503*REF(X72,5)-0.00102704*REF(X72,6)-0.000131447*REF(X72,7)-0.0000169351*REF(X72,8));

    X74:=IFF(CURRBARSCOUNT>1,XMA(X73,3),0.740524*X73+0.35541*REF(X73,1)-0.0316004*REF(X73,2)-0.0374119*REF(X73,3)-0.0218805*REF(X73,4)-0.00386503*REF(X73,5)-0.00102704*REF(X73,6)-0.000131447*REF(X73,7)-0.0000169351*REF(X73,8));

    X75:=IFF(CURRBARSCOUNT>1,XMA(X74,3),0.740524*X74+0.35541*REF(X74,1)-0.0316004*REF(X74,2)-0.0374119*REF(X74,3)-0.0218805*REF(X74,4)-0.00386503*REF(X74,5)-0.00102704*REF(X74,6)-0.000131447*REF(X74,7)-0.0000169351*REF(X74,8));

    X76:=IFF(CURRBARSCOUNT>1,XMA(X75,3),0.740524*X75+0.35541*REF(X75,1)-0.0316004*REF(X75,2)-0.0374119*REF(X75,3)-0.0218805*REF(X75,4)-0.00386503*REF(X75,5)-0.00102704*REF(X75,6)-0.000131447*REF(X75,7)-0.0000169351*REF(X75,8));

    X77:=IFF(CURRBARSCOUNT>1,XMA(X76,3),0.740524*X76+0.35541*REF(X76,1)-0.0316004*REF(X76,2)-0.0374119*REF(X76,3)-0.0218805*REF(X76,4)-0.00386503*REF(X76,5)-0.00102704*REF(X76,6)-0.000131447*REF(X76,7)-0.0000169351*REF(X76,8));

    X78:=IFF(CURRBARSCOUNT>1,XMA(X77,3),0.740524*X77+0.35541*REF(X77,1)-0.0316004*REF(X77,2)-0.0374119*REF(X77,3)-0.0218805*REF(X77,4)-0.00386503*REF(X77,5)-0.00102704*REF(X77,6)-0.000131447*REF(X77,7)-0.0000169351*REF(X77,8));

    X79:=IFF(CURRBARSCOUNT>1,XMA(X78,3),0.740524*X78+0.35541*REF(X78,1)-0.0316004*REF(X78,2)-0.0374119*REF(X78,3)-0.0218805*REF(X78,4)-0.00386503*REF(X78,5)-0.00102704*REF(X78,6)-0.000131447*REF(X78,7)-0.0000169351*REF(X78,8));

    X80:IFF(CURRBARSCOUNT>1,XMA(X79,3),0.740524*X79+0.35541*REF(X79,1)-0.0316004*REF(X79,2)-0.0374119*REF(X79,3)-0.0218805*REF(X79,4)-0.00386503*REF(X79,5)-0.00102704*REF(X79,6)-0.000131447*REF(X79,7)-0.0000169351*REF(X79,8)),COLORYELLOW,DOTLINE;

    T:=(C+L+H)/3;

    SL:=((REF(T,1)*REF(V,1)+T*V)/(REF(V,1)+V));

    VV:=SL;

    Y911:=IFF(CURRBARSCOUNT=1, (XMA(VV,9)*9-MA(VV,8)+MA(VV,7) -MA(VV,6)+MA(VV,5) -MA(VV,4)+MA(VV,3) -MA(VV,2) +VV)/9,XMA(VV,9));

    Y912:=IFF(CURRBARSCOUNT=1, (XMA(Y911,9)*9-MA(Y911,8)+MA(Y911,7) -MA(Y911,6)+MA(Y911,5) -MA(Y911,4)+MA(Y911,3) -MA(Y911,2) +Y911)/9,XMA(Y911,9));

    Y913:=IFF(CURRBARSCOUNT=1, (XMA(Y912,9)*9-MA(Y912,8)+MA(Y912,7) -MA(Y912,6)+MA(Y912,5) -MA(Y912,4)+MA(Y912,3) -MA(Y912,2) +Y912)/9,XMA(Y912,9));

    {中期趋势:Y913,LINETHICK2,COLORGREEN;}

    HA:X80*1.05,POINTDOT,COLORYELLOW;

    HC:X80*1.10,POINTDOT,COLORYELLOW;

    LA:X80*0.95,POINTDOT,COLORYELLOW;

    LC:X80*0.90,POINTDOT,COLORYELLOW;

    Y291:=IFF(CURRBARSCOUNT=1,(XMA(VV,29)*29-MA(VV,28)+MA(VV,27)-MA(VV,26)+MA(VV,25)-MA(VV,24)+MA(VV,23)-MA(VV,22)+MA(VV,21)-MA(VV,20)+MA(VV,19)-MA(VV,18)+MA(VV,17)-MA(VV,16)+MA(VV,15)-MA(VV,14)+MA(VV,13)-MA(VV,12)+MA(VV,11) -MA(VV,10)+MA(VV,9) -MA(VV,8)+MA(VV,7) -MA(VV,6)+MA(VV,5) -MA(VV,4)+MA(VV,3) -MA(VV,2)+VV)/29,XMA(VV,29));

    Y292:=IFF(CURRBARSCOUNT=1,(XMA(Y291,29)*29-MA(Y291,28)+MA(Y291,27)-MA(Y291,26)+MA(Y291,25)-MA(Y291,24)+MA(Y291,23)-MA(Y291,22)+MA(Y291,21)-MA(Y291,20)+MA(Y291,19)-MA(Y291,18)+MA(Y291,17)-MA(Y291,16)+MA(Y291,15)-MA(Y291,14)+MA(Y291,13)-MA(Y291,12)+MA(Y291,11) -MA(Y291,10)+MA(Y291,9) -MA(Y291,8)+MA(Y291,7) -MA(Y291,6)+MA(Y291,5) -MA(Y291,4)+MA(Y291,3) -MA(Y291,2)+Y291)/29,XMA(Y291,29));

    Y293:=IFF(CURRBARSCOUNT=1,(XMA(Y292,29)*29-MA(Y292,28)+MA(Y292,27)-MA(Y292,26)+MA(Y292,25)-MA(Y292,24)+MA(Y292,23)-MA(Y292,22)+MA(Y292,21)-MA(Y292,20)+MA(Y292,19)-MA(Y292,18)+MA(Y292,17)-MA(Y292,16)+MA(Y292,15)-MA(Y292,14)+MA(Y292,13)-MA(Y292,12)+MA(Y292,11) -MA(Y292,10)+MA(Y292,9) -MA(Y292,8)+MA(Y292,7) -MA(Y292,6)+MA(Y292,5) -MA(Y292,4)+MA(Y292,3) -MA(Y292,2)+Y292)/29,XMA(Y292,29));

    {长期趋势:Y293,LINETHICK2,COLORGREEN;}

    IF(X80>=REF(X80,1),X80,DRAWNULL),COLORRED,LINETHICK2;

    {IF(X80<REF(X80,1),X80,DRAWNULL),COLORGREEN,LINETHICK2;}

    高险区1:=Y293*1.10,COLORLICYAN;

    高风区2:=Y293*1.125,COLORLICYAN;

    高风区3:Y293*1.150,COLORLICYAN;

    良机区1:=Y293*0.90,COLORLIBLUE;

    良机区2:=Y293*0.875,COLORLIBLUE;

    良机区3:Y293*0.85,COLORLIBLUE;
    CB财经网:致力于为用户打造一个正规可靠的股票配资、炒股经验分享交流平台。

    本文标题:「指数」通达信主力骗钱点,底部选股,优化MACD主图指标 地址: http://www.lagzc.com/gppz/11149.html

    免责声明:部分文章信息来源于网络以及网友投稿,本网站只负责对文章进行整理、排版、编辑,是出于传递 更多信息之目的,并不意味着赞同其观点或证实其内容的真实性,如本站文章和转稿涉及版权等问题,请作者在及时联系本站,我们会尽快和您对接处理。
    上证指数大盘实时行情
    十大配资平台
    名称 是否实盘 网址
    中天创投 访问
    京海策略 访问
    简配资 访问
    久联优配 访问
    杨方配资 待验证 访问
    鸿牛配资 待验证 访问
    申捷策略 待验证 访问
    涵星配资 待验证 访问
    简配资 待验证 访问
    金桥大通 待验证 访问
    广告

    网站首页 - 股票配资 - 期货配资 - 外汇配资 - 股票行情 - 正规配资平台 - 配资资讯 - 配资技巧 - 配资公司 - 投资理财 - 用户须知

    本站不良内容举报联系客服QQ:549784242 官方微信:549784242 服务热线:549784242

    合作平台: 百度财经 东方财富官网 股票配资 新浪财经行情 搜狐股票 雪球

    备案号:粤ICP备18029120号 技术支持:CB财经网

    未经本站书面特别授权,请勿转载或建立镜像

    Copyright © 2002-2020 CB财经网新闻资讯网 版权所有
    t>