网站地图
  • 股票配资
  • 期货配资
  • 外汇配资
  • 股票行情
  • 正规配资平台
  • 配资资讯
  • 配资技巧
  • 配资公司
  • 投资理财
  • 用户须知
  • 「筹码」通达信源码:动态筹码 筹码主图 彩色筹码,经纬操盘线

    文章来源:CB财经网 发布时间: 2020-03-20 09:14:54作者:伟琦阅读()
    动态筹码 筹码主图 彩色筹码:

     {动态筹码}

    现价获利比例:WINNER(CLOSE)*100,NODRAW;
    XA_1:=COST(0.1);
    XA_2:=COST(99.900002);
    XA_3:=(XA_2-XA_1)/10;
    STICKLINE((WINNER(XA_1+XA_3)-WINNER(XA_1))*100>1,XA_1,XA_1+XA_3,3,0),COLOR000066;
    STICKLINE((WINNER(XA_1+XA_3*2)-WINNER(XA_1+XA_3))*100>1,XA_1+XA_3,XA_1+XA_3*2,3,0),COLOR5533FF;
    STICKLINE((WINNER(XA_1+XA_3*3)-WINNER(XA_1+XA_3*2))*100>1,XA_1+XA_3*2,XA_1+XA_3*3,3,0),COLOR7777FF;
    STICKLINE((WINNER(XA_1+XA_3*4)-WINNER(XA_1+XA_3*3))*100>1,XA_1+XA_3*3,XA_1+XA_3*4,3,0),COLORWHITE;
    STICKLINE((WINNER(XA_1+XA_3*5)-WINNER(XA_1+XA_3*4))*100>1,XA_1+XA_3*4,XA_1+XA_3*5,3,0),COLORFFCC00;
    STICKLINE((WINNER(XA_1+XA_3*6)-WINNER(XA_1+XA_3*5))*100>1,XA_1+XA_3*5,XA_1+XA_3*6,3,0),COLORCC6600;
    STICKLINE((WINNER(XA_1+XA_3*7)-WINNER(XA_1+XA_3*6))*100>1,XA_1+XA_3*6,XA_1+XA_3*7,3,0),COLOR663300;
    STICKLINE((WINNER(XA_1+XA_3*8)-WINNER(XA_1+XA_3*7))*100>1,XA_1+XA_3*7,XA_1+XA_3*8,3,0),COLOR006633;
    STICKLINE((WINNER(XA_1+XA_3*9)-WINNER(XA_1+XA_3*8))*100>1,XA_1+XA_3*8,XA_1+XA_3*9,3,0),COLOR009933;
    STICKLINE((WINNER(XA_2)-WINNER(XA_1+XA_3*9))*100>1,XA_1+XA_3*9,XA_2,3,0),COLOR00DD33;
    筹一:(WINNER(XA_1+XA_3)-WINNER(XA_1))*100,NODRAW;
    筹二:(WINNER(XA_1+XA_3*2)-WINNER(XA_1+XA_3))*100,NODRAW;
    筹三:(WINNER(XA_1+XA_3*3)-WINNER(XA_1+XA_3*2))*100,NODRAW;
    筹四:(WINNER(XA_1+XA_3*4)-WINNER(XA_1+XA_3*3))*100,NODRAW;
    筹五:(WINNER(XA_1+XA_3*5)-WINNER(XA_1+XA_3*4))*100,NODRAW;
    筹六:(WINNER(XA_1+XA_3*6)-WINNER(XA_1+XA_3*5))*100,NODRAW;
    筹七:(WINNER(XA_1+XA_3*7)-WINNER(XA_1+XA_3*6))*100,NODRAW;
    筹八:(WINNER(XA_1+XA_3*8)-WINNER(XA_1+XA_3*7))*100,NODRAW;
    筹九:(WINNER(XA_1+XA_3*9)-WINNER(XA_1+XA_3*8))*100,NODRAW;
    筹十:(WINNER(XA_2)-WINNER(XA_1+XA_3*9))*100,NODRAW;
    DRAWNUMBER(筹一>1,XA_1+XA_3,INTPART(筹一)),COLOR7777FF;
    DRAWNUMBER(筹二>1,XA_1+XA_3*2,INTPART(筹二)),COLOR7777FF;
    DRAWNUMBER(筹三>1,XA_1+XA_3*3,INTPART(筹三)),COLORWHITE;
    DRAWNUMBER(筹四>1,XA_1+XA_3*4,INTPART(筹四)),COLOR7777FF;
    DRAWNUMBER(筹五>1,XA_1+XA_3*5,INTPART(筹五)),COLORWHITE;
    DRAWNUMBER(筹六>1,XA_1+XA_3*6,INTPART(筹六)),COLORFFCC00;
    DRAWNUMBER(筹七>1,XA_1+XA_3*7,INTPART(筹七)),COLORFFCC00;
    DRAWNUMBER(筹八>1,XA_1+XA_3*8,INTPART(筹八)),COLOR00DD33;
    DRAWNUMBER(筹九>1,XA_1+XA_3*9,INTPART(筹九)),COLOR00DD33;
    DRAWNUMBER(筹十>1,XA_2,INTPART(筹十)),COLORWHITE;
    DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
    现价:CLOSE,COLOR99FFFF,LINETHICK2;
    浮筹:(WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))/WINNER(HHV(HIGH,0))*100,NODRAW,COLOR99FFFF,LINETHICK3;
    前段:筹一+筹二+筹三,NODRAW,COLORWHITE;
    中段:筹四+筹五+筹六+筹七,NODRAW,COLORGREEN;
    后段:筹八+筹九+筹十,NODRAW,COLORRED;
    换手:DYNAINFO(37)*100,NODRAW;
    量比:DYNAINFO(17),NODRAW;
     
    {筹码主图}
    成交量显示:=1;
    MA5:MA(CLOSE,5);
    MA10:MA(CLOSE,10);
    MA20:MA(CLOSE,20);
    MA60:MA(CLOSE,60);
    VAR1:=COST(90);
    VAR2:=COST(70);
    VAR3:=COST(50);
    VAR4:=COST(30);
    VAR5:=COST(2);
    VAR6:=INTPART(COST(2)*100)/100;
    VAR7:=INTPART(COST(0.01)*100)/100;
    筹码牛熊:EMA((VAR1+VAR2+VAR3+VAR4+VAR5)/5,3),COLORYELLOW,LINETHICK3;
    VAR8:=COST(90)>REF(COST(90),1) AND COST(70)>REF(COST(70),1) AND COST(50)>REF(COST(50),1) AND COST(30)>REF(COST(30),1);
    VAR9:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>6 AND VAR8 AND CLOSE>COST(90) AND LOW<COST(90) AND (LOW-筹码牛熊)/筹码牛熊*100<5;
    STICKLINE(VAR9,OPEN,CLOSE,2.4,0),COLORYELLOW;
    DRAWICON(VAR9,LOW*0.97,26);
    VAR10:=FILTER((CLOSE-COST(2))/COST(2)*100<3 AND CLOSE>VAR6 AND VAR6>=REF(VAR6,1),3);
    DRAWICON(VAR10,LOW*0.97,38);
    VAR11:=BARSLAST(VAR10);
    VAR12:=BARSLAST(VAR7<REF(VAR7,1) AND REF(VAR7,1)>=REF(VAR7,2));
    DRAWICON(VAR7<REF(VAR7,1) AND REF(VAR7,1)>=REF(VAR7,2) AND REF(VAR11,1)<REF(VAR12,1),HIGH*1.01,39);
    STICKLINE(VAR10,OPEN,CLOSE,2,0),COLORYELLOW;
    DRAWNUMBER(CURRBARSCOUNT=1 AND CLOSE>0,筹码牛熊,(CLOSE-筹码牛熊)/筹码牛熊*100),COLORWHITE;
    VAR13:=48;
    VAR14:=48;
    VAR15:=CONST(LLV(LOW,VAR13))*0.85;
    VAR16:=VOL/(EMA(VOL,250)/EMA(CLOSE,250)*VAR14);
    VAR17:=CLOSE/VAR16;
    VAR18:=HIGH/VAR16;
    VAR19:=LOW/VAR16;
    VAR20:=OPEN/VAR16;
    VAR21:=VAR16/((VAR18-VAR19)*2-ABS(VAR17-VAR20));
    VAR22:=IF(VAR17>VAR20,VAR21*(VAR18-VAR19),IF(VAR17<VAR20,VAR21*(VAR18-VAR20+(VAR17-VAR19)),VAR16/2));
    VAR23:=IF(VAR17>VAR20,0-VAR21*(VAR18-VAR17+(VAR20-VAR19)),IF(VAR17<VAR20,0-VAR21*(VAR18-VAR19),0-VAR16/2));
    STICKLINE(CLOSE>OPEN AND 成交量显示=1,VAR16+VAR15,VAR22+VAR15,0.5,0),COLOR7777FF;
    STICKLINE(CLOSE>OPEN AND 成交量显示=1,VAR15,VAR22+VAR15,0.5,0),COLOR7777FF;
    STICKLINE(CLOSE<OPEN AND 成交量显示=1,VAR16+VAR15,VAR22+VAR15,0.5,0),COLOR00DD33;
    STICKLINE(CLOSE<OPEN AND 成交量显示=1,VAR15,VAR22+VAR15,0.5,0),COLOR00DD33;

     
    {彩色筹码}
    HJ_1:=COST(0.1);
    HJ_2:=COST(99.900002);
    HJ_3:=(HJ_2-HJ_1)/10;
    红色筹码:INTPART((WINNER(HJ_1+HJ_3*3)-WINNER(HJ_1))*100),COLOR5533FF,LINETHICK3;
    蓝色筹码:INTPART((WINNER(HJ_1+HJ_3*7)-WINNER(HJ_1+HJ_3*4))*100),COLORCC6600,LINETHICK3;
    绿色筹码:INTPART((WINNER(HJ_2)-WINNER(HJ_1+HJ_3*7))*100),COLOR009933,LINETHICK3;




    经纬操盘线( CB财经 股票学院: http://www.lagzc.com ):

    {短线英豪}
    动力线:MA(C,5),LINETHICK3,COLOR00CCFF;
    牛熊线:MA(C,13),CIRCLEDOT,COLORYELLOW;
    生命线:MA(C,34),CIRCLEDOT,COLORMAGENTA;
    MA05:=MA(C,5);
    MA10:=MA(C,10);
    MA20:=MA(C,20);
    MA30:=MA(C,30);
    五日乖离率:=(C-MA05)/MA05*100;
    BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
    速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);
    加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
    IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORRED;
    BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
    IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORGREEN;
    三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;
    VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
    VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);
    BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
    强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
    加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA05>REF(MA05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)
    AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10) ;
    清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30) AND MA05<REF(MA05,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);
    DRAWTEXT(加仓 ,LOW*0.98,'◆加二'),COLORYELLOW;
    JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;
    减仓:=FILTER(JC,10);
    MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
    买入:=FILTER(MR,10);
    DRAWTEXT(减仓,HIGH*1.02,'◆风险'),COLORCYAN;
    DRAWTEXT(买入,LOW*0.96,'◆买二'),COLORYELLOW;
    DRAWTEXT(清仓 ,HIGH*1.00,'◆清仓'),COLORGREEN;
    VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
    VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
    MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;
    压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;
    支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;
    {彩色K线}
    TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
    TYX4:=MA((C+L+O+H)/4,13);
    TYX5:=EMA((C+L+O+H)/4,21);
    {空心红}
    STICKLINE(C<TYX5 AND C>O,H,L,0,0),COLORRED;
    STICKLINE(C<TYX5 AND C>O,C,O,3,1),COLORRED;
    {深绿}
    STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700;
    STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR005500;
    STICKLINE(C<TYX5 AND C<O,C,O,2,0),COLOR006600;
    STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007700;
    {蓝}
    STICKLINE(C>TYX5 AND C<O,H,L,0,0),COLORFFDD44;
    STICKLINE(C>TYX5 AND C<O,C,O,3,0 ),COLORFF7700;
    STICKLINE(C>TYX5 AND C<O,C,O,2,0 ),COLORFFAA22;
    STICKLINE(C>TYX5 AND C<O,C,O,1 ,0 ),COLORFFDD44;
    {黄}
    STICKLINE(C>TYX5 AND C>O,H,L,0,0 ),COLOR00EEFF;
    STICKLINE(C>TYX5 AND C>O,C,O,3,0 ),COLOR00AAFF;
    STICKLINE(C>TYX5 AND C>O,C,O,2,0 ),COLOR00CCFF;
    STICKLINE(C>TYX5 AND C>O,C,O,1,0 ),COLOR00EEFF;
     
    {粉红}
    STICKLINE(C>TYX4 AND C>O,H,L,0,0),COLORFF66AA;
    STICKLINE(C>TYX4 AND C>O,C,O,3,0 ),COLORFF11FF;
    STICKLINE(C>TYX4 AND C>O,C,O,2,0 ),COLORFF44FF;
    STICKLINE(C>TYX4 AND C>O,C,O,1,0 ),COLORFF66FF;
    {亮灰}
    STICKLINE(C>TYX4 AND C<O,H,L,0,0),COLOR999999;
    STICKLINE(C>TYX4 AND C<O,C,O,3,0),COLOR555555;
    STICKLINE(C>TYX4 AND C<O,C,O,2,0),COLOR777777;
    STICKLINE(C>TYX4 AND C<O,C,O,1,0),COLOR999999;
    {深红}
    STICKLINE(C>TYX3 AND C>O,H,L,0,0),COLOR0000DD;
    STICKLINE(C>TYX3 AND C>O,C,O,3,0),COLOR000099;
    STICKLINE(C>TYX3 AND C>O,C,O,2,0),COLOR0000BB;
    STICKLINE(C>TYX3 AND C>O,C,O,1,0),COLOR0000DD;
     
    {涨跌停K线}
    STICKLINE(HIGH=LOW AND CLOSE=OPEN  AND (CLOSE/REF(CLOSE,1))>1.048,HIGH,LOW,3,0) ,COLORRED;
    STICKLINE(HIGH=LOW AND CLOSE=OPEN  AND (REF(CLOSE,1)/CLOSE)>1.048,HIGH,LOW,3,0) ,COLOR00FF00;
    {突破}
    STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,1,0),COLOR00CCFF;
    {买卖主图}
    MA18:=MA(CLOSE,18);
    MTM:=C-REF(C,1);
    DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
    买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
    DRAWTEXT(FILTER(买=1,5),LOW,'★买一'),COLORRED;
    加1:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
    DRAWTEXT(加1,LOW*0.99,'★加一'),COLORCC66FF;
    卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
    DRAWTEXT(FILTER(卖一=1,1),HIGH*1.01,'★卖一'),COLORGREEN;
    {牛熊通吃}
    AA1:=AMOUNT/V;
    BB1:=L<AA1*0.9;
    CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
    DD1:=L<MA(C,5)*0.921;
    EE1:=V<MA(V,5)*1.5;
    FF1:=BB1 AND CC1 AND DD1 AND EE1;
    DRAWTEXT(FF1,LOW*0.99,'老鼠仓'),COLOR4080FF;
    {预测明天}
    XXS:=MA(LOW,5)*(1-5/100);
    XXS1:=MA(HIGH,5)*(1+5/100);
    均线:=C,COLORGREEN;
    AAAA:=CLOSE/REF(CLOSE,3)<=0.85 AND CROSS(C,XXS) AND C>REF(C,1),LINETHICK0 ;
    DRAWTEXT(AAAA,L*0.95,'下影买'),COLORRED;
    BBAA:=CROSS(XXS1,C);
    DRAWTEXT(CROSS(XXS1,C),H,'开盘逃'),COLORWHITE;
    DDDD:=CROSS(C,XXS1);
    DRAWTEXT(DDDD,H,'明日走'),COLORYELLOW;
    {兄弟指标}
    AAA:=MA(LOW,5)*(1-5/100);
    BBB:=(HHV(AAA,5)+LLV(AAA,5))/2;
    DRAWTEXT(CROSS(BBB,L) AND BBB>REF(BBB,1),L*0.98,'←兄弟回马枪'),COLORWHITE;
    {天河指标}
    DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIF,9);
    DRAWTEXT(REF(CROSS(DEA,DIF),1) AND CROSS(DIF,DEA),L*0.97,'←天河回马抢'),COLORMAGENTA;
    {见好就收}
    VSR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
    VSR3:=SMA(VSR2,4,1);
    VSR4:=SMA(VSR3,2,1);
    DRAWTEXT(VSR4>82 AND VSR3>89,HHV(C,30)*1.02,'收'),COLORGREEN;
     

    CB财经网:致力于为用户打造一个正规可靠的股票配资、炒股经验分享交流平台。

    本文标题:「筹码」通达信源码:动态筹码 筹码主图 彩色筹码,经纬操盘线 地址: http://www.lagzc.com/gppz/11186.html

    免责声明:部分文章信息来源于网络以及网友投稿,本网站只负责对文章进行整理、排版、编辑,是出于传递 更多信息之目的,并不意味着赞同其观点或证实其内容的真实性,如本站文章和转稿涉及版权等问题,请作者在及时联系本站,我们会尽快和您对接处理。
    上证指数大盘实时行情
    十大配资平台
    名称 是否实盘 网址
    中天创投 访问
    京海策略 访问
    简配资 访问
    久联优配 访问
    杨方配资 待验证 访问
    鸿牛配资 待验证 访问
    申捷策略 待验证 访问
    涵星配资 待验证 访问
    简配资 待验证 访问
    金桥大通 待验证 访问
    广告

    网站首页 - 股票配资 - 期货配资 - 外汇配资 - 股票行情 - 正规配资平台 - 配资资讯 - 配资技巧 - 配资公司 - 投资理财 - 用户须知

    备案号:粤ICP备12525258029120号 技术支持:CB财经网

    Copyright © 2002-2020 CB123456财经网新闻资讯网 版权所有t>