网站地图
  • 股票配资
  • 期货配资
  • 外汇配资
  • 股票行情
  • 正规配资平台
  • 配资资讯
  • 配资技巧
  • 配资公司
  • 投资理财
  • 用户须知
  • 「偏离」通达信源码:小白龙,量价潜伏,股海必买

    文章来源:CB财经网 发布时间: 2020-03-20 09:15:33作者:炜宁阅读()
    小白龙:

    上轨:EMA(H,55),COLORGREEN;

    下轨:EMA(L,55),COLORGREEN;

    A1:=PLOYLINE(C>上轨,上轨);

    NOTEXT_A2:IF(C>上轨,A1,DRAWNULL),COLORRED;

    B1:=PLOYLINE(C>下轨,下轨);

    NOTEXT_B2:IF(C>下轨,B1,DRAWNULL),COLORRED;

    DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;DEA:=EMA(DIF,9);MACD:=(DIF-DEA)*2;

    {神龙抄底13号}

    CDYH:=DIF/C<-下偏离值 && DIF/C<0;

    抄底一号:=MACD>REF(MACD,1) && DIF<REF(DIF,1)*1.01 && CDYH,COLORWHITE;

    底一号:=抄底一号 AND REF(抄底一号,1)=0,COLORWHITE;

    DRAWTEXT(底一号,L*0.99,'←偏离'),COLORMAGENTA;

    JJCC:=CROSS(DIF,DEA);

    X0ZHH:=BARSLAST(CROSS(0,DIF))+1;

    SCCTS:=BARSLAST(CROSS(DEA,DIF))+1,NODRAW;

    DIFZDZ1:=LLV(DIF,SCCTS),NODRAW;

    GJJZDZ:=LLV(L,SCCTS),NODRAW;

    DIFZDZ2:=LLV(DIF,X0ZHH),NODRAW;

    DIFWS0ZZ:=HHV(DIF,SCCTS)<-0.08;

    LGLJXX:=REF(MACD,1)<0 && REF(MACD,2)<0;

    BLLL:=LGLJXX && DIFWS0ZZ && (DIFZDZ1>=REF(DIFZDZ1,SCCTS) || DIFZDZ1>=REF(DIFZDZ2,SCCTS)) && GJJZDZ<=REF(GJJZDZ,SCCTS);

    三号:=JJCC && DIF<0 && BLLL,COLORMAGENTA;

    DRAWTEXT(三号,L*0.99,'←背离'),COLORMAGENTA;

    {神龙逃顶13号}

    CCDD1:=DIF/C>上偏离值 && DIF/C>0;

    逃顶一号:=MACD<REF(MACD,1) && DIF>REF(DIF,1) && CCDD1,COLORWHITE;

    顶一号:=逃顶一号 AND REF(逃顶一号,1)=0,COLORWHITE;

    DRAWTEXT(顶一号,H*1.0,'←偏离'),COLORGREEN;

    JJC:=CROSS(DEA,DIF);

    X0ZHHL:=BARSLAST(CROSS(DIF,0))+1;

    SCCTSS:=BARSLAST(CROSS(DIF,DEA))+1,NODRAW;

    DIFZDZ11:=HHV(DIF,SCCTSS),NODRAW;

    GJJZDZZ:=HHV(H,SCCTSS),NODRAW;

    {DIFZDZ2:=HHV(DIF,X0ZHH),NODRAW;}

    DIFWS0ZZZ:=HHV(DIF,SCCTSS)>0.08;

    LGLJXXX:=REF(MACD,1)>0 && REF(MACD,2)>0;

    BLLLL:=LGLJXXX && DIFWS0ZZZ && (DIFZDZ11<=REF(DIFZDZ11,SCCTSS) {|| DIFZDZ11<=REF(DIFZDZ2,SCCTSS)}) && GJJZDZZ>=REF(GJJZDZZ,SCCTSS);

    顶三号:=JJC && DIF>0 && BLLLL,COLORMAGENTA;

    DRAWTEXT(顶三号,H*1.0,'←背离'),COLORGREEN;




    量价潜伏:

    重在潜伏为首选,但又要在趋势相对稳定确定下找机会,也就是通用的5日线金叉10日线后的机会。

     
     
    量价副图源码如下:
    VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
    主动买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,
    VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
    主动卖盘:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),
    IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2));
    主动:=SUM(主动买盘,0)/SUM(主动卖盘,0)*-1;
    低主5:=LLV(主动,5);
    动比:=主动-低主5;
    高动5:=6/HHV(动比,5);
    主动心:=高动5*动比;
    K1:=主动心+1-REF(主动心,1)>0;
    K2:=主动心+1-REF(主动心,1)<0;
    主动心向:=主动心*K1-主动心*K2;
    {下面是量价了相合}
    FF:=CLOSE-REF(CLOSE,1);
    A:=MA(VOL*FF,2);
    A0:=MA(VOL*FF,3);
    A1:=MA(VOL*FF,5);
    A2:=MA(VOL*FF,10);
    A3:=MA(VOL*FF,20);
    A4:=MA(VOL*FF,30);
    B:=A-REF(A,1);
    B0:=A0-REF(A0,1);
    B1:=A1-REF(A1,1);
    B2:=A2-REF(A2,1);
    B3:=A3-REF(A3,1);
    B4:=A3-REF(A4,1);
    量价相合:(B>0)+(B0>0)+(B1>0)+(B2>0)+(B3>0)+(B4>0);
    YES:(量价相合>1)*量价相合*(主动心向>1 OR 主动心>60);
    IF(YES>=REF(YES,1),量价相合,0),COLORGREEN,LINETHICK2;
    IF(YES>=REF(YES,1),YES,0),COLORRED,LINETHICK2;
    周期1:IF(YES,BARSLAST(CROSS(YES,0.1))+1,0),COLORFF00FF,POINTDOT,LINETHICK5;
    5,COLORGREEN;
     
    {量价潜伏选股}
    量:(v/REF(V,1))-REF((v/REF(V,1)),1),COLORRED,LINETHICK2;
    价:(((c-REF(C,1))/REF(C,1)*100)-REF(((c-REF(C,1))/REF(C,1)*100),1))/2,coloryellow,LINETHICK2;
    量价齐升:2;量价齐跌:-2;




    股海必买:

    {股海全仓}

    N:=1;
    MA5:=MA(CLOSE,5);
    MA10:=MA(CLOSE,10);
    MA13:=MA(CLOSE,13);
    MA20:=MA(CLOSE,20);
    MA30:=MA(CLOSE,30);
    MA54:=MA(CLOSE,54);
    MA60:=MA(CLOSE,60),COLOR00FF99,LINETHICK2;
    MA120:=MA(CLOSE,120);
    HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
    HJ_9:=FILTER(HJ_8,10);
    HJ_10:=BARSLAST(HJ_9);
    HJ_11:=REF(HIGH,HJ_10+2);
    HJ_12:=REF(HIGH,HJ_10+1);
    HJ_13:=REF(HIGH,HJ_10);
    HJ_14:=MAX(HJ_11,HJ_12);
    HJ_15:=MAX(HJ_14,HJ_13);
    HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
    HJ_17:=HJ_10<150;
    HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;
    HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;
    HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
    HJ_21:=VOL/MA(VOL,5)<3.5;
    HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
    HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;
    暴利:=FILTER(HJ_25,15);
    PL1:=(((CLOSE-MA54)/MA54)<0.1);
    PL2:=(((CLOSE-MA10)/MA10)<0.3);
    偏离率:=(((PL1=1) AND (PL2=1))*0.2);
    平台突破:=((((偏离率=0) AND (REF(偏离率,1)=0.2)) AND (REF((COUNT((偏离率=0.2),10)=10),1)=1))*-0.1);
    妖股突破:=平台突破=-0.1;
    XDF:=(暴利 OR 妖股突破);
    VARA:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
    VARAA:=DYNAINFO(7)/(REF(CLOSE,1))>1.05 AND (DYNAINFO(7)/O>1.05);
    FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
    妖股:=XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA,NODRAW;
    工作线:=MA("KDJ.J#WEEK"(9,3,3),5);
    建仓:=CROSS(工作线,5),NODRAW,COLORMAGENTA;
    加仓:=CROSS(工作线,50),NODRAW,COLORYELLOW;
    VAR1:=工作线,COLORRED;
    持股:=IF(VAR1>REF(VAR1,1),VAR1,DRAWNULL),COLORRED;
    {股海必买}
    ZZAA1:=C<O; {昨天收阴线的}
    ZZAA2:=C>O AND C<REF(C,1);{假阴真阳的}
    ZZBB1:=REF(ZZAA1,1) AND C>REF(O,1);
    ZZBB2:=REF(ZZAA2,1) AND C>REF(C,1);
    BM:=ZZBB1 OR ZZBB2;
    T:=BARSLAST(妖股);
    必买:=T>=1 AND  T<=20 AND BM ; 
    TJ1:=C/REF(C,1)*100-100;
    TJ2:=TJ1>6;
    TJ3:=MAX(C,O)/MIN(C,O)*100-100;
    TJ4:=TJ3<5;
    TJ5:=BARSLASTCOUNT(TJ4);
    TJ6:=TJ5>=2 AND TJ5<=4; 
    TJ7:=REF(TJ6,1) AND TJ2;
    TJ8:=REF(TJ2,1) AND TJ4;
    TJ9:=BARSLAST(TJ8);
    TJ10:=TJ9<8;
    A:=C/REF(C,1)>1.095 AND H=O AND L=H;
    上升三法:=REF(TJ6,1) AND TJ1>N AND TJ10 AND NOT(A);
    XG:必买 AND 上升三法 AND 持股<100 AND 持股;
     
     
     

    {股海全仓主图}
    {公式名称: 乾坤三线
    公式描述: 乾坤三线( CB财经 股票学院: http://www.lagzc.com )
    无参数
    公式类型: 技术指标公式-均线型
    画线方法: 主图叠加
    公式版本: 0
    显示小数: 缺省位数
    坐标线位置: 自动
    额外Y轴分界: 无
    参数精灵:无
    用法注释:
    1.股价高于平均线,视为强势;股价低于平均线,视为弱势
    2.平均线向上涨升,具有助涨力道;平均线向下跌降,具有助跌力道;
    3.二条以上平均线向上交叉时,买进;
    4.二条以上平均线向下交叉时,卖出;
    5.移动平均线的信号经常落后股价,若以EXPMA 、VMA 辅助,可以改善。
    公式源码:}
     
    所属地区:DRAWTEXT_FIX(1,0.00,0.05,0,'地区:'),COLORFFFF00;
    DRAWTEXT_FIX(1,0.05,0.05,0,DYBLOCK),COLORFFFF00;
    所属行业:DRAWTEXT_FIX(1,0,0.10,0,'行业:'),COLORFFFF00;
    DRAWTEXT_FIX(1,0.05,0.10,0,HYBLOCK),COLORFFFF00;
    所属概念:DRAWTEXT_FIX(1,0,0.15,0,'概念:'),COLORFFFF00;
    DRAWTEXT_FIX(1,0.05,0.15,0,GNBLOCK),COLORFFFF00;
    所属风格:DRAWTEXT_FIX(1,0,0.20,0,'风格:'),COLORFFFF00;
    DRAWTEXT_FIX(1,0.05,0.20,0,FGBLOCK),COLORFFFF00;
    上市日期:=CONST(DAYTODATE((DATETODAY(DATE)-FINANCE(42))))+19000000,NODRAW;
    DRAWTEXT_FIX(1,0,0.25,0,'上市日期:'),COLORFFFF00;
    DRAWNUMBER_FIX(1,0.05,0.25,0,上市日期),COLORFFFF00;
    A1:MA(CLOSE,5);
    A2:MA(CLOSE,6);
    A3:MA(CLOSE,7);
    B1:EMA(MEMA(CLOSE,13),13),COLORGREEN;
    B2:EMA(MEMA(CLOSE,14),14),COLORGREEN;
    B3:EMA(MEMA(CLOSE,15),15),COLORF00FF0;
    KY1:EMA(MEMA(CLOSE,80),80),COLORFF9900;
    KY2:EMA(MEMA(CLOSE,84),84),COLORRED,LINETHICK3;
    IF(KY2<REF(KY2,1),KY2,DRAWNULL),COLORGREEN,LINETHICK3;
    KY3:EMA(MEMA(CLOSE,88),88),COLORF00FF0;
    X_1:=IF(NAMELIKE(1) OR NAMELIKE(2),0.05,0.1);
    X_2:=CLOSE/REF(CLOSE,1)-1>=X_1-0.01/REF(CLOSE,1) AND CLOSE=HIGH AND PERIOD=5;
    STICKLINE(X_2,CLOSE,OPEN,(-1),0),COLORFF00F5;
    X_3:=REF(CLOSE,1)/CLOSE-1>=X_1-0.01/REF(CLOSE,1) AND LOW=CLOSE AND PERIOD=5;
    STICKLINE(X_3,CLOSE,OPEN,(-1),0),COLORGREEN;
    X_4:=HIGH/REF(CLOSE,1)-1>=X_1-0.01/REF(CLOSE,1) AND CLOSE<HIGH AND PERIOD=5;
    STICKLINE(X_4,HIGH-(HIGH-MAX(OPEN,CLOSE)),HIGH,0,0),COLORFF00B5;
    X_5:=REF(CLOSE,1)/LOW-1>=X_1-0.01/REF(CLOSE,1) AND LOW<CLOSE AND PERIOD=5;
    STICKLINE(X_5,LOW+(MIN(OPEN,CLOSE)-LOW),LOW,0,0),COLOR00BB00;
    X_6:=OPEN/REF(CLOSE,1)-1>=X_1-0.01/REF(CLOSE,1) AND OPEN=HIGH AND PERIOD=5;
    STICKLINE(X_6,CLOSE+(OPEN-CLOSE)*0.9,OPEN,(-1),0),COLORFF00F5;
    X_7:=REF(CLOSE,1)/OPEN-1>=X_1-0.01/REF(CLOSE,1) AND LOW=OPEN AND PERIOD=5;
    STICKLINE(X_7,CLOSE-(CLOSE-OPEN)*0.9,OPEN,(-1),0),COLORGREEN;
     
    {总股本}
    M:=88;
    N1:=6;
    N2:=60;
    YYP:=0;
    SHORT:=21;
    LONG:=44;
    DD:=0;
    板块排序:HORCALC('板块指数',105,1,0),NODRAW,COLORRED;
    MA5:=MA(CLOSE,5);
    MA10:=MA(CLOSE,10);
    MA13:=MA(CLOSE,13);
    MA20:=MA(CLOSE,20);
    MA30:=MA(CLOSE,30);
    MA54:=MA(CLOSE,54);
    MA60:=MA(CLOSE,60),COLOR00FF99,LINETHICK2;
    MA120:=MA(CLOSE,120);
    STICKLINE(C/REF(C,1)>=1.096 AND H=C,O,C,2,0),COLORYELLOW;
    HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
    HJ_9:=FILTER(HJ_8,10);
    HJ_10:=BARSLAST(HJ_9);
    HJ_11:=REF(HIGH,HJ_10+2);
    HJ_12:=REF(HIGH,HJ_10+1);
    HJ_13:=REF(HIGH,HJ_10);
    HJ_14:=MAX(HJ_11,HJ_12);
    HJ_15:=MAX(HJ_14,HJ_13);
    HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
    HJ_17:=HJ_10<150;
    HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;
    HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;
    HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
    HJ_21:=VOL/MA(VOL,5)<3.5;
    HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
    HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;
    暴利:=FILTER(HJ_25,15);
    PL1:=(((CLOSE-MA54)/MA54)<0.1);
    PL2:=(((CLOSE-MA10)/MA10)<0.3);
    偏离率:=(((PL1=1) AND (PL2=1))*0.2);
    平台突破:=((((偏离率=0) AND (REF(偏离率,1)=0.2)) AND (REF((COUNT((偏离率=0.2),10)=10),1)=1))*-0.1);
    妖股突破:=平台突破=-0.1;
    XDF:=(暴利 OR 妖股突破);
    VARA:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
    VARAA:=DYNAINFO(7)/(REF(CLOSE,1))>1.05 AND (DYNAINFO(7)/O>1.05);
    FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
    妖股:XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA,NODRAW;
    DRAWICON(妖股,LOW*0.995,7);
    DRAWTEXT(妖股,LOW*0.975,' 妖股'),COLORYELLOW;
    {倍量}
    BL:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
    获利比例:WINNER(C)*100,NODRAW,COLORRED;
    {火鸟出击}
    AM1:=C/REF(C,1)>1.095 AND C=H;
    H1:=(REF(C,1)/REF(C,2)<0.96) OR (REF(O,1)/REF(C,1)>1.05);
    H2:=C/REF(C,1)>1.041 AND C>REF(O,1);
    XGH1:=H1 AND H2;
    XGY:=XGH1;
    ABXG:=COUNT(REF(AM1,3),10) AND XGY;
    DRAWICON(ABXG,L*0.98,24);
    DRAWTEXT(ABXG,L*0.95,'出击'),COLORYELLOW;
    KM1:=C/REF(C,1)>1.095 AND C=H;
    DM1:=C/REF(C,1)>1.041 AND L<MA(C,5) AND C>MA(C,5) AND L<MA(C,10) AND C>MA(C,10) AND L<MA(C,20) AND C>MA(C,20) 
    AND ((L<MA(C,60)AND C>MA(C,60)) OR (L<MA(C,120)AND C>MA(C,120)));
    KDXG:=COUNT(REF(KM1,3),10) AND DM1;
    DRAWICON(KDXG,L*0.93,22);
    DRAWTEXT(KDXG,L*0.91.5,'绝密买点'),COLORRED;
    {股海必买}
    ZZAA1:=C<O; {昨天收阴线的}
    ZZAA2:=C>O AND C<REF(C,1);{假阴真阳的}
    ZZBB1:=REF(ZZAA1,1) AND C>REF(O,1);
    ZZBB2:=REF(ZZAA2,1) AND C>REF(C,1);
    必买:ZZBB1 OR ZZBB2;
    T:=BARSLAST(妖股);
    股海必买:=T>1 AND  T<20 AND 必买; 
    DRAWICON(股海必买,L*0.94,25);
    DRAWTEXT(股海必买,L*0.92.5,'必买'),COLORRED;
    A:=AMOUNT/V/100;
    VARAB:=EMA((((A-EMA(A,13))/EMA(A,13))*(0-100)),5);
    QQ:=EMA(((VARAB/10)+EMA(A,13)),0);
    行情线:=MA(A,1);
    重心:=(C+0.618*REF(C,1)+0.382*REF(C,1)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
    【操盘线】:EMA(((SLOPE(C,22)*20)+C),55),COLORYELLOW,LINETHICK4;
    【黄金线】:IF(重心>=【操盘线】,【操盘线】,DRAWNULL),COLORRED,LINETHICK2;
    【空仓线】:IF(重心<【操盘线】,【操盘线】,DRAWNULL),COLORCYAN,LINETHICK2;
    DRAWTEXT(ISLASTBAR,【操盘线】,'【操盘线】'),COLORRED;
     
     
     
    {股海必买主图}
    {公式名称: 乾坤三线
    公式描述: 乾坤三线
    无参数
    公式类型: 技术指标公式-均线型
    画线方法: 主图叠加
    公式版本: 0
    显示小数: 缺省位数
    坐标线位置: 自动
    额外Y轴分界: 无
     
    参数精灵:无
    用法注释:
    1.股价高于平均线,视为强势;股价低于平均线,视为弱势
    2.平均线向上涨升,具有助涨力道;平均线向下跌降,具有助跌力道;
    3.二条以上平均线向上交叉时,买进;
    4.二条以上平均线向下交叉时,卖出;
    5.移动平均线的信号经常落后股价,若以EXPMA 、VMA 辅助,可以改善。
    公式源码:}
     
    所属地区:DRAWTEXT_FIX(1,0.00,0.05,0,'地区:'),COLORFFFF00;
    DRAWTEXT_FIX(1,0.05,0.05,0,DYBLOCK),COLORFFFF00;
    所属行业:DRAWTEXT_FIX(1,0,0.10,0,'行业:'),COLORFFFF00;
    DRAWTEXT_FIX(1,0.05,0.10,0,HYBLOCK),COLORFFFF00;
    所属概念:DRAWTEXT_FIX(1,0,0.15,0,'概念:'),COLORFFFF00;
    DRAWTEXT_FIX(1,0.05,0.15,0,GNBLOCK),COLORFFFF00;
    所属风格:DRAWTEXT_FIX(1,0,0.20,0,'风格:'),COLORFFFF00;
    DRAWTEXT_FIX(1,0.05,0.20,0,FGBLOCK),COLORFFFF00;
    上市日期:=CONST(DAYTODATE((DATETODAY(DATE)-FINANCE(42))))+19000000,NODRAW;
    DRAWTEXT_FIX(1,0,0.25,0,'上市日期:'),COLORFFFF00;
    DRAWNUMBER_FIX(1,0.05,0.25,0,上市日期),COLORFFFF00;
    A1:MA(CLOSE,5);
    A2:MA(CLOSE,6);
    A3:MA(CLOSE,7);
    B1:EMA(MEMA(CLOSE,13),13),COLORGREEN;
    B2:EMA(MEMA(CLOSE,14),14),COLORGREEN;
    B3:EMA(MEMA(CLOSE,15),15),COLORF00FF0;
    KY1:EMA(MEMA(CLOSE,80),80),COLORFF9900;
    KY2:EMA(MEMA(CLOSE,84),84),COLORRED,LINETHICK3;
    IF(KY2<REF(KY2,1),KY2,DRAWNULL),COLORGREEN,LINETHICK3;
    KY3:EMA(MEMA(CLOSE,88),88),COLORF00FF0;
    X_1:=IF(NAMELIKE(1) OR NAMELIKE(2),0.05,0.1);
    X_2:=CLOSE/REF(CLOSE,1)-1>=X_1-0.01/REF(CLOSE,1) AND CLOSE=HIGH AND PERIOD=5;
    STICKLINE(X_2,CLOSE,OPEN,(-1),0),COLORFF00F5;
    X_3:=REF(CLOSE,1)/CLOSE-1>=X_1-0.01/REF(CLOSE,1) AND LOW=CLOSE AND PERIOD=5;
    STICKLINE(X_3,CLOSE,OPEN,(-1),0),COLORGREEN;
    X_4:=HIGH/REF(CLOSE,1)-1>=X_1-0.01/REF(CLOSE,1) AND CLOSE<HIGH AND PERIOD=5;
    STICKLINE(X_4,HIGH-(HIGH-MAX(OPEN,CLOSE)),HIGH,0,0),COLORFF00B5;
    X_5:=REF(CLOSE,1)/LOW-1>=X_1-0.01/REF(CLOSE,1) AND LOW<CLOSE AND PERIOD=5;
    STICKLINE(X_5,LOW+(MIN(OPEN,CLOSE)-LOW),LOW,0,0),COLOR00BB00;
    X_6:=OPEN/REF(CLOSE,1)-1>=X_1-0.01/REF(CLOSE,1) AND OPEN=HIGH AND PERIOD=5;
    STICKLINE(X_6,CLOSE+(OPEN-CLOSE)*0.9,OPEN,(-1),0),COLORFF00F5;
    X_7:=REF(CLOSE,1)/OPEN-1>=X_1-0.01/REF(CLOSE,1) AND LOW=OPEN AND PERIOD=5;
    STICKLINE(X_7,CLOSE-(CLOSE-OPEN)*0.9,OPEN,(-1),0),COLORGREEN;
    MA5:=MA(CLOSE,5);
    MA10:=MA(CLOSE,10);
    MA13:=MA(CLOSE,13);
    MA20:=MA(CLOSE,20);
    MA30:=MA(CLOSE,30);
    MA54:=MA(CLOSE,54);
    MA60:=MA(CLOSE,60),COLOR00FF99,LINETHICK2;
    MA120:=MA(CLOSE,120);
    HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
    HJ_9:=FILTER(HJ_8,10);
    HJ_10:=BARSLAST(HJ_9);
    HJ_11:=REF(HIGH,HJ_10+2);
    HJ_12:=REF(HIGH,HJ_10+1);
    HJ_13:=REF(HIGH,HJ_10);
    HJ_14:=MAX(HJ_11,HJ_12);
    HJ_15:=MAX(HJ_14,HJ_13);
    HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
    HJ_17:=HJ_10<150;
    HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;
    HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;
    HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
    HJ_21:=VOL/MA(VOL,5)<3.5;
    HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
    HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;
    暴利:=FILTER(HJ_25,15);
    PL1:=(((CLOSE-MA54)/MA54)<0.1);
    PL2:=(((CLOSE-MA10)/MA10)<0.3);
    偏离率:=(((PL1=1) AND (PL2=1))*0.2);
    平台突破:=((((偏离率=0) AND (REF(偏离率,1)=0.2)) AND (REF((COUNT((偏离率=0.2),10)=10),1)=1))*-0.1);
    妖股突破:=平台突破=-0.1;
    XDF:=(暴利 OR 妖股突破);
    VARA:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
    VARAA:=DYNAINFO(7)/(REF(CLOSE,1))>1.05 AND (DYNAINFO(7)/O>1.05);
    FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
    妖股:=XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA,NODRAW;
    工作线:=MA("KDJ.J#WEEK"(9,3,3),5);
    建仓:=CROSS(工作线,5),NODRAW,COLORMAGENTA;
    加仓:=CROSS(工作线,50),NODRAW,COLORYELLOW;
    VAR1:=工作线,COLORRED;
    持股:=IF(VAR1>REF(VAR1,1),VAR1,DRAWNULL),COLORRED;
    {股海必买}
    ZZAA1:=C<O; {昨天收阴线的}
    ZZAA2:=C>O AND C<REF(C,1);{假阴真阳的}
    ZZBB1:=REF(ZZAA1,1) AND C>REF(O,1);
    ZZBB2:=REF(ZZAA2,1) AND C>REF(C,1);
    BM:=ZZBB1 OR ZZBB2;
    T:=BARSLAST(妖股);
    必买:=T>=1 AND  T<=20 AND BM ; 
    TJ1:=C/REF(C,1)*100-100;
    TJ2:=TJ1>6;
    TJ3:=MAX(C,O)/MIN(C,O)*100-100;
    TJ4:=TJ3<5;
    TJ5:=BARSLASTCOUNT(TJ4);
    TJ6:=TJ5>=2 AND TJ5<=4; 
    TJ7:=REF(TJ6,1) AND TJ2;
    TJ8:=REF(TJ2,1) AND TJ4;
    TJ9:=BARSLAST(TJ8);
    TJ10:=TJ9<8;
    AA:=C/REF(C,1)>1.095 AND H=O AND L=H;
    上升三法:=REF(TJ6,1) AND TJ1>2 AND TJ10 AND NOT(AA);
    XG:必买 AND 上升三法 AND 持股<100 AND 持股;
    {倍量}
    BL:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
    获利比例:WINNER(C)*100,NODRAW,COLORRED;
    DRAWICON(XG,L*0.99,25);
    DRAWTEXT(XG,L*0.97.5,'全仓'),COLORGREEN;
    A:=AMOUNT/V/100;
    VARAB:=EMA((((A-EMA(A,13))/EMA(A,13))*(0-100)),5);
    QQ:=EMA(((VARAB/10)+EMA(A,13)),0);
    行情线:=MA(A,1);
    重心:=(C+0.618*REF(C,1)+0.382*REF(C,1)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
    【操盘线】:EMA(((SLOPE(C,22)*20)+C),55),COLORYELLOW,LINETHICK4;
    【黄金线】:IF(重心>=【操盘线】,【操盘线】,DRAWNULL),COLORRED,LINETHICK2;
    【空仓线】:IF(重心<【操盘线】,【操盘线】,DRAWNULL),COLORCYAN,LINETHICK2;
    DRAWTEXT(ISLASTBAR,【操盘线】,'【操盘线】'),COLORRED;
    CB财经网:致力于为用户打造一个正规可靠的股票配资、炒股经验分享交流平台。

    本文标题:「偏离」通达信源码:小白龙,量价潜伏,股海必买 地址: http://www.lagzc.com/gppz/11230.html

    免责声明:部分文章信息来源于网络以及网友投稿,本网站只负责对文章进行整理、排版、编辑,是出于传递 更多信息之目的,并不意味着赞同其观点或证实其内容的真实性,如本站文章和转稿涉及版权等问题,请作者在及时联系本站,我们会尽快和您对接处理。
    上证指数大盘实时行情
    十大配资平台
    名称 是否实盘 网址
    中天创投 访问
    京海策略 访问
    简配资 访问
    久联优配 访问
    杨方配资 待验证 访问
    鸿牛配资 待验证 访问
    申捷策略 待验证 访问
    涵星配资 待验证 访问
    简配资 待验证 访问
    金桥大通 待验证 访问
    广告

    网站首页 - 股票配资 - 期货配资 - 外汇配资 - 股票行情 - 正规配资平台 - 配资资讯 - 配资技巧 - 配资公司 - 投资理财 - 用户须知

    本站不良内容举报联系客服QQ:549784242 官方微信:549784242 服务热线:549784242

    合作平台: 百度财经 东方财富官网 股票配资 新浪财经行情 搜狐股票 雪球

    备案号:粤ICP备18029120号 技术支持:CB财经网

    未经本站书面特别授权,请勿转载或建立镜像

    Copyright © 2002-2020 CB财经网新闻资讯网 版权所有
    t>