网站地图
  • 股票配资
  • 期货配资
  • 外汇配资
  • 股票行情
  • 正规配资平台
  • 配资资讯
  • 配资技巧
  • 配资公司
  • 投资理财
  • 用户须知
  • 「通道」同花顺源码:黑马通道上升趋势,庄底,CGP短长线附图

    文章来源:CB财经网 发布时间: 2020-04-15 10:45:31作者:子健阅读()
    1、黑马通道上升趋势

    钦差黑马震仓绝佳上升趋势

    Var5:=LLV(LOW,75);

    Var6:=HHV(HIGH,75);

    Var7:=(Var6-Var5)/100;

    Var8:=SMA((CLOSE-Var5)/Var7,23,1);

    A1A:=EMA(CLOSE, 9);

    A1B:=((A1A - EMA(CLOSE, 5)) < 0);

    A1C:=((A1A - EMA(CLOSE, 5)) > 0);

    A1D:=BARSLAST(A1B);

    VarA:=3*Var8-2*SMA(Var8,13,1);

    VARb:=LLV(LOW,23);

    VARc:=HHV(HIGH,23);

    A1E:=BARSLAST(A1C);

    A1F:=IF((A1E > 0),(CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,0);

    VARd:=EMA((VARa-VARb)/(VARc-VARb)*100,13);

    VARe:=EMA(0.778*REF(VARd,1)+0.222*VARd,30);

    VARF:=TROUGHBARS(3,6,1)<4 AND CROSS(VARD,VARE);

    A20:=SUM(A1F,0);

    A21:=IF((A1D > 0),(0 - 2),0);

    A22:=IF((A1E > 0),SUM((CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,A1E),0);

    VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);

    VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

    VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

    VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

    A23:=A22 / A1E;

    A25:=EMA(EMA(EMA(CLOSE, 3), 3), 3);

    VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

    VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

    VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

    VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

    VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

    VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);

    上升通道:((A25 - REF(A25, 1)) + A25),colorred;

    反转通道:MA(上升通道, 15),colorgreen;

    VAR1A:=EMA(VAR19,100);

    VAR1B:=2*(VAR19-VAR1A);

    VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);

    VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));

    IF(上升通道>REF(上升通道,1),上升通道,DRAWNULL),COLORFFFFCC,LINETHICK4,POINTDOT;

    IF(反转通道>REF(反转通道,1),反转通道,DRAWNULL),COLOR00FFFF,LINETHICK4,POINTDOT;

    VAR1E:=EMA(VAR1D*0.97,3);

    VAR1F:=(HIGH+LOW+CLOSE)/3;

    VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV(VAR1F,14));

    VAR21:=CROSS(VAR1E,LOW);

    STICKLINE((上升通道 > 反转通道),反转通道,上升通道,1,0),colormagenta;

    上升通道选股:IF((上升通道 > 反转通道),反转通道,上升通道,10,0),colorred;

    STICKLINE((反转通道 > 上升通道),上升通道,反转通道, 1, 0),COLORFF0000;

    选股买点: VAR10, , coloryellow;

    组合买: (VAR11+VAR13+VAR15+VAR17), , colorred;

    组合卖: (VAR12+VAR14+VAR16+VAR18), , colorgreen;

    DRAWTEXT(CROSS(反转通道,上升通道),上升通道 * 1.08,''),COLOR00FF00;

    DRAWTEXT(CROSS(上升通道,反转通道),反转通道 * 0.97,'上升趋势'),COLOR0000FF;

    黑马线: IF(MONTH<2008 AND VAR1B>0.1,VAR1C,0)*1, , COLOR6699CC;

    黑马信号介入点: 选股买点 AND VARF AND VARC AND VAR21 AND VAR5<2 AND VAR6=0, , COLORFFFF99;




    2、庄底, 发现庄and抄底 个股与大盘 三合一

    VAR1:=EMA(HHV(HIGH,500),21);
    VAR2:=EMA(HHV(HIGH,250),21);
    VAR3:=EMA(HHV(HIGH,90),21);
    VAR4:=EMA(LLV(LOW,500),21);
    VAR5:=EMA(LLV(LOW,250),21);
    VAR6:=EMA(LLV(LOW,90),21);
    VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
    VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
    VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
    VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
    VARB:=REF(LOW,1);
    VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
    VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
    VARE:=LLV(LOW,30);
    VARF:=HHV(VARD,30);
    VAR10:=IF(MA(CLOSE,58),1,0);
    SS: EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10,NODRAW;
    发现庄:(REF(SS,2)<REF(SS,1)AND SS>REF(SS,1))*SS,colormagenta,LINETHICK2;
    买:(REF(发现庄,1)>0 AND 发现庄=0)*20;
    var1xx:=REF(CLOSE,1);
    var2xx:=SMA(MAX(CLOSE-var1xx,0),7,1)/SMA(ABS(CLOSE-var1xx),7,1)*100,coloryellow;
    varxx21:IF(var2xx<20,40,20),colorblue;
    varxx22:IF(var2xx>80,60,80),COLORFFFF50;
    var2xx↑:STICKLINE(FILTER(REF(var2xx,1)<20 AND var2xx>REF(var2xx,1),5),20,40,8,0),colorred;
    var2xx↓:STICKLINE(FILTER(REF(var2xx,1)>80 AND var2xx<REF(var2xx,1),5),60,80,8,0),COLORFFFF50;
    DRAWTEXT(FILTER(REF(var2xx,1)<20 AND var2xx>REF(var2xx,1),5),40 ,'买入' ),COLORFFFFFF;
    DRAWTEXT(FILTER(REF(var2xx,1)>80 AND var2xx<REF(var2xx,1),5),60 ,'卖出' ),COLORFFFFFF;
    VARyy1:=(HHV(HIGH,3)-LLV(LOW,3));
    VARyy2:=(HHV(HIGH,9)-CLOSE);
    VARyy3:=(CLOSE-LLV(LOW,9));
    VARyy4:=VARyy2/VARyy1*100-70 ;
    VARyy5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
    VARyy6:=(2*C+H+L)/4;
    VARyy7:=SMA((VARyy3/VARyy1*100),3,1);
    VARyy8:=LLV(LOW,27);
    VARyy9:=SMA(VARyy7,3,1)-SMA(VARyy4,7,1);
    VARyy10:= IF(VARyy9>100,VARyy9-100,0);
    VARyyA:=HHV(HIGH,27);
    主力: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK;
    见底信号: 10, LINETHICK2,colorbrown ;
    早点上车: IF(主力<=10,50,10), LINETHICK2;
    买入时机: IF(CROSS(主力,见底信号),100,10),LINETHICK,coloryellow;
    个股能量线:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), colorred,NODRAW;
    大盘能量线:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),colorgreen,NODRAW;



    3、CGP短长线附图( CB财经 股票学院: http://www.lagzc.com )

    RSV=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

    a1=SMA(RSV,3,1);
    b1=SMA(a1,3,1);
    e1=3*a1-2*b1;
    短线:e1,colorwhite;
    长期:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),colorred,LINETHICK2;
    a2=SMA(长期,10,1);
    b2=SMA(a2,10,1);
    e2=3*a2-2*b2;
    长线:e2,colorred,LINETHICK2;
    长辅线:SMA(长线,3,1),coloryellow;;
    超强:100,POINTDOT,colorgreen;
    强势线:80,POINTDOT,colorliblue;
    分水岭:50,POINTDOT,coloryellow;
    弱势线:20,POINTDOT,colorred;
    地平线:0,POINTDOT,colorligreen;
    DIFF : =EMA(CLOSE,12) - EMA(CLOSE,26);
    DEA  : =EMA(DIFF,9);
    MACD : 2*(DIFF-DEA),NODRAW;
    STICKLINE(MACD>0 ,20,20,6,0),colorred,colorred,LINETHICK6;
    STICKLINE(MACD<0 ,20,20,6,0),colorred,colorgreen,LINETHICK6;
    CB财经网:致力于为用户打造一个正规可靠的股票配资、炒股经验分享交流平台。

    本文标题:「通道」同花顺源码:黑马通道上升趋势,庄底,CGP短长线附图 地址: http://www.lagzc.com/gppz/11607.html

    免责声明:部分文章信息来源于网络以及网友投稿,本网站只负责对文章进行整理、排版、编辑,是出于传递 更多信息之目的,并不意味着赞同其观点或证实其内容的真实性,如本站文章和转稿涉及版权等问题,请作者在及时联系本站,我们会尽快和您对接处理。
    上证指数大盘实时行情
    十大配资平台
    名称 是否实盘 网址
    中天创投 访问
    京海策略 访问
    简配资 访问
    久联优配 访问
    杨方配资 待验证 访问
    鸿牛配资 待验证 访问
    申捷策略 待验证 访问
    涵星配资 待验证 访问
    简配资 待验证 访问
    金桥大通 待验证 访问
    广告

    网站首页 - 股票配资 - 期货配资 - 外汇配资 - 股票行情 - 正规配资平台 - 配资资讯 - 配资技巧 - 配资公司 - 投资理财 - 用户须知

    本站不良内容举报联系客服QQ:549784242 官方微信:549784242 服务热线:549784242

    合作平台: 百度财经 东方财富官网 股票配资 新浪财经行情 搜狐股票 雪球

    备案号:粤ICP备18029120号 技术支持:CB财经网

    未经本站书面特别授权,请勿转载或建立镜像

    Copyright © 2002-2020 CB财经网新闻资讯网 版权所有
    t>