网站地图
  • 股票配资
  • 期货配资
  • 外汇配资
  • 股票行情
  • 正规配资平台
  • 配资资讯
  • 配资技巧
  • 配资公司
  • 投资理财
  • 用户须知
  • 「军师」通达信源码:买入卖出点,飞天买进,私募短线出击优化升级

    文章来源:CB财经网 发布时间: 2020-05-20 11:49:29作者:炜宁阅读()
    1、买入卖出点,黄色底部就是买入点成功率80%-90%

    买入卖出点
    公式介绍:
    公式很简单,容易掌握
    个股和大盘都适用
    具体如下图:
    黄色底部就是买入点,绿色顶部就是卖出点,
    简单说就是:黄托买入绿顶卖出。
    成功率80%-90%。大家可以导入验证一下。

    {买入卖出点}
     
    V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20); 
     V2:=(1-7/100)*(DMA(CLOSE,V1));
     V3:=(1+7/100)*(DMA(CLOSE,V1));
     V5:=MA((LOW+HIGH+CLOSE)/3,5);
    支撑:REFDATE(V2,DATE),POINTDOT,LINETHICK3,COLORCC66FF;
    阻力:REFDATE(V3,DATE),POINTDOT,LINETHICK3,COLORGREEN;
     VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
     VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
     VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
     VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
     VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
     VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
     VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
     VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
     VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
     VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
     VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
     VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
     VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
     VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
     VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
     VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
     VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
     VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
     VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
     VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
     VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
     VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
     VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
     VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
     VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
     VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
     STICKLINE(VAR19,L,L*0.98,3,0),COLORYELLOW;
     VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR 
     VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
     STICKLINE(VAR1A,H*1.01,H,3,0),COLOR00FF00{98FD};
     MA3:MA(C,3);
     MA5:MA(C,5),COLORWHITE;
     MA10:=MA(C,10),NODRAW;
     MA30:MA(C,34),NODRAW;
    五日乖离率:=(C-MA5)/MA5*100;
     BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
     IF(BB5>30 AND MA5>REF(MA5,1), MA5,DRAWNULL),LINETHICK1,COLORRED;
     BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
     IF(BB5<0 AND MA5<REF(MA5,1), MA5,DRAWNULL),LINETHICK1,COLORGREEN;
     DD5:=MA5<REF(MA5,1);
     IF(DD5,MA5,DRAWNULL),COLOR00FF00;
     X:=(3*C+L+O+H)/6;
    多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
     +13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
     +7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
     REF(X,20))/210,COLORFF00FF,LINETHICK1;
     {用法:黄托底买进,绿压顶买出。}
    DD:=多空线<REF(多空线,1);
     IF(DD,多空线,DRAWNULL),COLORBLUE,LINETHICK2;
     A:=(MA5>多空线);
    IF(A,多空线,DRAWNULL),COLORYELLOW,POINTDOT;
     A1:=(MA5<多空线);
    IF(A1,多空线,DRAWNULL),COLORWHITE;
     A2:=3*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);
     A4:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;
     A5:=EMA(CLOSE,12)-EMA(CLOSE,26);
     A6:=EMA(A5,9);
     A7:=(A5<-0.1 AND A5>A6);
    财神:IF(A7,LLV(L,21),DRAWNULL)COLORRED,CIRCLEDOT;
     CYS:=(EMA((CLOSE-V2)/V2,1)*100);
     AA:=CYS;
     MIDD:=MA(CYS,20);
     CC:=MIDD+0.85*STD(CYS,10);
     TM6:=AA>CC;
     IF(TM6,MA5,DRAWNULL),COLORRED,LINETHICK1;
     A0:=(L+H+C*2)/4;
    工作:=EMA(A0,14)COLORYELLOW,LINETHICK1;
    度假:=EMA(A0,25)COLORYELLOW,LINETHICK1;
     A1X:=(工作-REF(工作,1))/REF(工作,1)*100;
     A2X:=(度假-REF(度假,1))/REF(度假,1)*100;
     G:=BARSLAST(CROSS(A1X,0));
     {KDJ}
     RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
     K:=SMA(RSV,3,1);
     D:=SMA(K,3,1);
     J:=3*K-2*D;
    金叉:=CROSS(J,D);
    死叉:=CROSS(D,J);
    买1:=(VAR14 OR VAR15) AND VAR11;
    买2:=(VAR14 OR VAR15) AND VAR4;
    买3:=(VAR14 OR VAR15) AND VAR2;
    买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);
    买5:=(金叉 AND VAR4) OR (金叉 AND VAR2) OR (金叉 AND VAR11);
     {涨停}
    STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),COLOR00FFFF;
     {跌停}
    STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),COLORGREEN;
     {蓝}
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;
     STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;
     STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;
     STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;
     {红} 
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;
     STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;
     STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF; 
     STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
     {绿} 
    STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,3,0),COLOR009900; 
     STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,2.2,0),COLOR00BB00; 
     STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,1.5,0),COLOR00DD00; 
     STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,0.5,0),COLOR00FF00;
     {灰} 
    STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;
     STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB; 
     STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD; 
     STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;
     STICKLINE(金叉,OPEN,CLOSE,0.5,0),COLORYELLOW;
     STICKLINE(死叉,OPEN,CLOSE,0.5,0),COLOR000099;
     DRAWICON(VAR16,LOW-0.02,7);
     DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5,LOW-0.01,1);
     DRAWICON(死叉 OR VAR12 OR CROSS(40,VAR9),HIGH+0.01,2);
     STICKLINE(CROSS(A1X,0),C,O,1,0)COLORFFFFFF;
     STICKLINE(CROSS(0,A1X),C,O,1,0)COLORGREEN;




    2、飞天买进,实战性很强

    飞天买进是一个副图公式,可以综合选股,
    本人上图的是自己根据此指标改进的盘中预警选股公式来的。
     
    公式的表现:
    本月的盘中预警到现在共出20个票,几乎均摊一天一票,自然了,有的交易日没出票,有的一天出两三个票,以此来说明这个附图指标的实战性,绝对吊打好多金钻指标,( CB财经 股票学院: http://58188.com )
    就以当天预警出来的票进入第二天出,20只失败一只,牛股就有六七只,
    这还是这个月大盘天天阴跌的战绩,
    懂者自懂,智者见智,欢迎到分析家公式网,有缘自会共同战斗~~~
     
    {================背景 ================};
    DRAWGBK(CURRBARSCOUNT=1, RGB(0,0,0),RGB(0,0,0),0,'1',0);
    顶:90,COLORRED,LINETHICK1;
    强:80,COLORRED,LINETHICK1;
    弱:05,COLORGREEN,LINETHICK1;
    DRAWTEXT(ISLASTBAR,  顶,'  顶'),COLORYELLOW;
    DRAWTEXT(ISLASTBAR,  强,'  强'),COLORRED;
    DRAWTEXT(ISLASTBAR,  弱,'  弱'),COLORGREEN;
    VAR1:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
    VAR22:=SMA(VAR1,20,1);
    VAR33:=SMA(VAR22,15,1);
    VAR44:=(3*VAR22+2*VAR33)/4;
    VAR55:= REF(VAR44,1);
    RSA:SMA(MAX(VAR44-VAR55,0),2,1)/SMA(ABS(VAR44-VAR55),2,1)*100 ,COLORRED,NODRAW ,LINETHICK1;  
    RSB:MA(RSA,10),NODRAW;
    拉升:IF(CROSS(RSA,RSB),20,0),STICK,COLORRED ,LINETHICK2,NODRAW;
    落袋:IF(CROSS(RSB,90),20,0),STICK ,LINETHICK2,NODRAW;
    DRAWTEXT(CROSS(RSA,RSB),10,'拉升'),COLORRED  ;
    DRAWTEXT(CROSS(RSB,90),15,'落袋'),COLORGREEN ;
    DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIFF,9),COLORWHITE;
    MACD:=(DIFF-DEA)*2;
    A:STICKLINE(MACD>=0 AND MACD>=REF(MACD,1) AND REF(MACD,1)<0
    AND MACD>=0.01,90,MACD,2,1) ,COLORGREEN;
    DRAWTEXT(A,90,'飞天'),COLORYELLOW ;
    启动线:=10*SUM(EMA((C+L)/2,2),5)/10.158,NODRAW;
    平衡线:=10*LLV(SUM( EMA((C+L)/2,2),5)/10.158,4),NODRAW;
    平台线:=10*LLV(SUM( EMA((C+L)/2,2),5)/10.158,10),NODRAW;
    强弱线:=EMA(启动线,21);
    VVAR1:=2*MA(LLV((C+L)/2,8)*1.1,13)-EMA((C+L)/2,3)-((C+L)/2)*0.1;
    VVAR2:=IF((EMA((C+L)/2,3)-VVAR1)*5>0,POW((EMA((C+L)/2,3)-VVAR1)*5,2)/10,-1*POW((EMA((C+L)/2,3)-VVAR1)*5,2)/10);
    VVAR3:=IF(VVAR2>0,VVAR2-0,0);
    STICKLINE(VVAR3>0 AND REF(VVAR3,1)=0 AND (C+L)/2>MA((C+L)/2,8),0,35,2,0),COLORYELLOW;
    DRAWTEXT(VVAR3>0 AND REF(VVAR3,1)=0 AND (C+L)/2>MA((C+L)/2,8),40,'动');
    散户:= 100*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60));
    RSV:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;
    RSV1:=(C-MA(C,4))/MA(C,4)*100;
    VAR2:=REF(LOW,1);
    VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
    VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
    VAR5:=LLV(LOW,30);
    VAR6:=HHV(VAR4,30);
    VAR7:=IF(MA(CLOSE,58),1,0);
    VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
    VAR9:=IF(VAR8>100,100,VAR8);
    K:=SMA(RSV,5,1);
    D:=SMA(K,3,1);
    J:=3*K-2*D;
    主力:=EMA(J,6),COLORYELLOW;
    AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
    AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
    AA5:=SMA(AA4,13,8);
    走势:=CEILING(SMA(AA5,13,8)),COLORRED,LINETHICK2;
    AA6:=SMA(AA3,21,8);
    {买观注: STICKLINE(走势-AA6<-65,0,7,15,2);}
    {DRAWICON(FILTER(J>REF(J,1)AND 走势>=REF(走势,1)AND 走势<25 ,5),走势,1);}
    {卖观注: STICKLINE(走势-AA6>85,98,90,15,1),COLORFFFF00;}
    {DRAWICON(FILTER(J<REF(J,1)AND 走势<=REF(走势,1)AND J>85 ,5),J,2);}
    吸:STICKLINE(VAR9>-120,50,50+(VAR9/2),3,1),COLORRED ;
    CDMA:EMA(EMA(RSV1,7),7)*4,NODRAW,COLORWHITE;
    STICKLINE(CDMA>=0 AND CDMA>=REF(CDMA,1),50,50+CDMA,3.3,0),COLORYELLOW ;{粉色拉升资金块}
    短线:100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10)),COLORWHITE ,NODRAW   ;
    {快线:(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,LINETHICK1,COLORWHITE   ;}
    散户线:散户,COLORGREEN ,   ;
    主力线:主力,COLORMAGENTA,LINETHICK1 ;
    拉升线:走势,COLORYELLOW,LINETHICK1;
    DRAWTEXT(ISLASTBAR,散户线,'←--空方线'),COLORGREEN;
    DRAWTEXT(ISLASTBAR,主力线,'←--主力线'),COLORMAGENTA ;
    DRAWTEXT(ISLASTBAR,拉升线,'←--拉升线'),COLORYELLOW;
     
    走强线: 20,COLORCYAN   ;
    关注低买:IF(90>散户 AND CROSS(90,散户) ,98,0),COLORMAGENTA,STICK,NODRAW;
    高抛低吸:IF(散户<10 AND CROSS(10,散户) ,20,0),COLORGREEN,STICK,NODRAW;
    风险:COUNT("RSI.RSI1"(6,12,24)>80,3)=3 AND  CROSS("RSI.RSI2"(6,12,24),79.5),NODRAW;
    观注顶:(散户<8 AND 主力>90 AND 走势>90 AND CDMA<=REF(CDMA,1)AND 散户线),COLORGREEN,NODRAW;
    DRAWTEXT(观注顶,-1,'◆'),COLORGREEN;
    DRAWTEXT(风险,100,'←风险'),COLOR00FFFF;
    STICKLINE(关注低买,0,35,3,1),COLORMAGENTA  ;
    {STICKLINE(高抛低吸,0,100,0,-1),COLORGREEN;};
    A77:=((CLOSE - (MA(CLOSE,13))) / (MA(CLOSE,13))) * -100;
    A78:=((CLOSE - (LLV(LOW,13))) / ((HHV(HIGH,13)) - (LLV(LOW,13)))) * 100;
    A79:=SMA(A78,3,2);
    A80:=SMA(A79,3,2);
    A81:=SMA(A80,5,1);
    VAK1:=IF(YEAR>=2038 AND MONTH>=1,0,1);
    VAK2:=REF(LOW,1)*VAK1;
    VAK3:=SMA(ABS(LOW-VAK2),3,1)/SMA(MAX(LOW-VAK2,0),3,1)*100*VAK1;
    VAK4:=EMA(IF(CLOSE*1.3,VAK3*10,VAK3/10),3)*VAK1;
    VAK5:=LLV(LOW,30)*VAK1;
    VAK6:=HHV(VAK4,30)*VAK1;
    VAK7:=IF(MA(CLOSE,58),1,0)*VAK1;
    VAK8:=EMA(IF(LOW<=VAK5,(VAK4+VAK6*2)/2,0),3)/618*VAK7*VAK1;
    吸筹:=IF(VAK8>100,100,VAK8)*VAK1;
    跟庄吸:=IF(吸筹<REF(吸筹,1) AND (REF(吸筹,1)>REF(吸筹,2) OR REF(吸筹,1)=100),1,0);
    吸筹累计:=SUM(吸筹,60);
    庄三吸:=COUNT(跟庄吸,30)=3 AND 跟庄吸=1 AND 吸筹累计>200;
    狠吸筹:=REF(吸筹,1)=100 AND 吸筹<REF(吸筹,1) AND 吸筹累计>260;
    狠吸筹2:=REF(吸筹,1)>REF(吸筹,2) AND 90<REF(吸筹,1) AND 吸筹<REF(吸筹,1) AND 吸筹累计>260;
    跟庄买:STICKLINE(庄三吸=1 OR 狠吸筹=1 OR 狠吸筹2=1,0,30,1,1),COLORFFFFFF;
    DRAWTEXT(跟庄买,40.4,'庄'),COLORFFFF00;
    股价趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0;
    底部警戒: 10,COLORRED,LINETHICK0;
    买入警戒:STICKLINE(股价趋势<=10,0,10,3,0),COLORMAGENTA     ;
    买入信号: STICKLINE(CROSS(股价趋势,底部警戒),0,30,1,1),COLORYELLOW     ,LINETHICK2;
    DRAWICON(CROSS(股价趋势,底部警戒),45,24);



    3、私募短线出击优化升级

    所有指标都有滞后性,该指标亲测有效率80%以上,大家可以验证参考( CB财经 股票学院: http://58188.com )

    {私募短线出击}
    JRH:=HHV(C,2);
    JRL:=LLV(C,2);
    MA3:=MA(CLOSE,3);
    YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
    VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
    VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
    VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
    VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
     
    红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
    军师离场:=IF(红色持股,JRL,DRAWNULL);
    明离场价:=军师离场,COLORFF99FF,NODRAW;
    今离场价:REF(军师离场,1)COLOR0000FF,NODRAW;
    青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
    进:=IF(青色观望,JRH,DRAWNULL);
    明进场价:=进,COLOR33AACC,NODRAW;
    今进场价:REF(明进场价,1),COLORFF0000,NODRAW;
    军师短买:VAR19,COLOR33AACC,NODRAW;
    品红离场:VAR1A,COLORFF99FF,NODRAW;
    急速超跌:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;
     
    辰星线:(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211,COLOR0000FF;
    牵牛线:MA(CLOSE,26),COLORFF00FF;
    等待:=IF(MA3>辰星线,辰星线,MA3);
     
    上市日期年:REF(YEAR,BARSCOUNT(CLOSE)-1),NODRAW,COLOR0000FF;
    月:REF(MONTH,BARSCOUNT(CLOSE)-1),NODRAW,COLORFF00FF;
    日:REF(DAY,BARSCOUNT(CLOSE)-1),NODRAW,COLOR00FFFF;
     
    IF(等待>REF(等待,1),等待,DRAWNULL),LINETHICK2,COLOR00FFFF;
    IF(辰星线>REF(辰星线,1),辰星线,DRAWNULL),LINETHICK2,COLOR0000FF;
    IF(辰星线<REF(辰星线,1),辰星线,DRAWNULL),COLOR00FF00;
    IF(牵牛线>REF(牵牛线,1),牵牛线,DRAWNULL),LINETHICK1,COLORFF00FF;
    IF(牵牛线<REF(牵牛线,1),牵牛线,DRAWNULL),COLOR669933;
    STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF;
    STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00;
    STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
    STICKLINE(C<O,L,H,0,0),COLOR999900;
    STICKLINE(1,C,O,3.5,0),COLOR858500;
    STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
    STICKLINE(红色持股,CLOSE,O,2.8,0),COLOR000055;
    STICKLINE(红色持股,CLOSE,O,2,0),COLOR000088;
    STICKLINE(红色持股,CLOSE,O,1.5,0),COLOR0000AA;
    STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000CC;
    STICKLINE(红色持股,CLOSE,O,0.5,0),COLOR0000EE;
    STICKLINE(青色观望,CLOSE,O,2.8,0),COLOR555500;
    STICKLINE(青色观望,CLOSE,O,2,0),COLOR888800;
    STICKLINE(青色观望,CLOSE,O,1.5,0),COLORAAAA00;
    STICKLINE(青色观望,CLOSE,O,1,0),COLORCCCC00;
    STICKLINE(青色观望,CLOSE,O,0.5,0),COLOREEEE00;
    CO:=(C-O);
    STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;
    STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;
    STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;
    STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;
    STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;
    STICKLINE(军师短买,O,O+CO/3,2.8,0),COLOR335555;
    STICKLINE(军师短买,O,O+CO/3,2,0),COLOR338888;
    STICKLINE(军师短买,O,O+CO/3,1.5,0),COLOR33AAAA;
    STICKLINE(军师短买,O,O+CO/3,1,0),COLOR33CCCC;
    STICKLINE(军师短买,O,O+CO/3,0,0),COLOR33EEEE;
    DRAWTEXT(军师短买,REF(CLOSE,1),'←军师短买'),COLOR33FFCC;
    STICKLINE(品红离场,O,O+CO/3,2.8,0),COLOR550055;
    STICKLINE(品红离场,O,O+CO/3,2,0),COLOR880088;
    STICKLINE(品红离场,O,O+CO/3,1.5,0),COLORAA00AA;
    STICKLINE(品红离场,O,O+CO/3,1,0),COLORCC00CC;
    STICKLINE(品红离场,O,O+CO/3,0.5,0),COLOREE00EE;
    DRAWTEXT(品红离场,REF(CLOSE,1)+0.1,'←军师离场'),COLORFF99FF;
    CB财经网:致力于为用户打造一个正规可靠的股票配资、炒股经验分享交流平台。

    本文标题:「军师」通达信源码:买入卖出点,飞天买进,私募短线出击优化升级 地址: http://www.lagzc.com/gppz/12188.html

    免责声明:部分文章信息来源于网络以及网友投稿,本网站只负责对文章进行整理、排版、编辑,是出于传递 更多信息之目的,并不意味着赞同其观点或证实其内容的真实性,如本站文章和转稿涉及版权等问题,请作者在及时联系本站,我们会尽快和您对接处理。
    上证指数大盘实时行情
    十大配资平台
    名称 是否实盘 网址
    中天创投 访问
    京海策略 访问
    简配资 访问
    久联优配 访问
    杨方配资 待验证 访问
    鸿牛配资 待验证 访问
    申捷策略 待验证 访问
    涵星配资 待验证 访问
    简配资 待验证 访问
    金桥大通 待验证 访问
    广告

    网站首页 - 股票配资 - 期货配资 - 外汇配资 - 股票行情 - 正规配资平台 - 配资资讯 - 配资技巧 - 配资公司 - 投资理财 - 用户须知

    本站不良内容举报联系客服QQ:549784242 官方微信:549784242 服务热线:549784242

    合作平台: 百度财经 东方财富官网 股票配资 新浪财经行情 搜狐股票 雪球

    备案号:粤ICP备18029120号 技术支持:CB财经网

    未经本站书面特别授权,请勿转载或建立镜像

    Copyright © 2002-2020 CB财经网新闻资讯网 版权所有
    t>