网站地图
  • 股票配资
  • 期货配资
  • 外汇配资
  • 股票行情
  • 正规配资平台
  • 配资资讯
  • 配资技巧
  • 配资公司
  • 投资理财
  • 用户须知
  • 「收盘价」通达信源码:十战七胜主图,九转正宗,安全点KDJ

    文章来源:CB财经网 发布时间: 2020-05-28 16:19:01作者:【博泽】阅读()
    1、十战七胜主图,追求十战十胜

    使用方法:出现黄色K线提示,不能马上买进,要参考附图指标(自用VOL),不然成功率就会降低,
    这个指标叫做十战七胜,我们追求的是十战十胜。所以要过滤一些错误的提示,有选择
    的参与,不能一看见提示就买入。( CB财经 股票学院: http://58188.com )

     {十战七胜}

     
    MAA5:=MA(C,5);
    MAA5_T:= ( (C+ C + REF(C,1) + REF(C,2) + REF(C,3) ) / 5 );
    MAA10:=MA(C,10);
    MAA20:=MA(C,20);
    MAA30:=MA(C,30);
    KS:=IF(MAA10>MAA30,MAA10,MAA30),COLORBLUE;
    A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
    A4:=SMA(A3,3,1);
    A5:=SMA(A4,3,1);
    A6:=3*A4-2*A5;
    A7:=C-REF(C,1);
    A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
    A9:=( (C-REF(C,1)) / REF(C,1) ) > 0.02;  {涨幅要大于2%}
    买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2)) AND A9;
    DRAWTEXT(FILTER(买=1,5),LOW*0.96,'买'), COLORMAGENTA;
    STICKLINE(买,OPEN,CLOSE,2,0),COLORMAGENTA;
    {显示1 到 10的数字}
    ZT:=BARSLAST(C/REF(C,1)-1>=0.1-0.01/REF(C,1) AND C=H);
    AQ:=EVERY(C>=REF(L,ZT),ZT);
    BQ:=IF(REF(AQ,ZT+1) AND REF(ZT,ZT+1)<13,REF(ZT,ZT+1)+ZT+1,ZT);
    DRAWTEXT(ZT<=10 AND AQ,              REF(L,ZT)*0.96, VAR2STR(ZT,0)),COLOR008000;
    DRAWTEXT(ZT>=6 AND ZT<=8 AND AQ,     REF(L,ZT)*0.96, VAR2STR(ZT,0)),COLORRED;
    DRAWTEXT(BQ>0 AND BQ<=10 AND BQ!=AQ, REF(L,BQ)*0.96, VAR2STR(BQ,0)),COLOR008000;
    DRAWTEXT(BQ>=6 AND BQ<=8 AND BQ!=AQ, REF(L,BQ)*0.96, VAR2STR(BQ,0)),COLORRED;
    {如果涨幅大于5%,显示黄色}
    涨幅5 := ( (C /REF(C,1)) > 1.05 ) AND ( (C /REF(C,1)) < 1.09 ) ;
    STICKLINE(涨幅5, CLOSE, OPEN, 1, 0),  COLOR8000FF;
    {如果涨停显示黄芯,如果跌停显示绿芯}
    涨停 := (C /REF(C,1)) > 1.095;
    STICKLINE(涨停, HIGH, OPEN, 0.9, 0), COLORYELLOW;
    {如果涨幅大于5%,显示黄色}
    跌幅5 := ( (C / REF(C,1)) < 0.95 ) ;
    STICKLINE(跌幅5, OPEN, CLOSE, 1, 0), COLOR400000;
    跌停 := C/REF(C,1) < 0.9 ;
    STICKLINE(跌停, HIGH, LOW, 1, 0), COLORGREEN;
    M5:MA(CLOSE,5),  LINETHICK2, COLORRED; {COLORWHITE;}
    MAA5_T, NODRAW;
    M10:MA(CLOSE,10),  COLORGREEN,  LINETHICK2;  {COLORLIRED}
    M20:MA(CLOSE,20), COLORFF00FF; {, LINETHICK2;}
    M30:MA(CLOSE,30), COLORGREEN, NODRAW; {,  LINETHICK2;}
    {显示当日价格线}
    DRAWLINE(CURRBARSCOUNT=90, CONST(C), CURRBARSCOUNT=1, C, 3),COLORBLUE,LINETHICK1;
    DRAWICON(CROSS(M10, C), H, 15);
    {显示20日线
    M20DAYS:=MA(CLOSE,20);
    DRAWLINE(CURRBARSCOUNT=TOTALBARSCOUNT,CONST(C),CURRBARSCOUNT=1,M20DAYS,3),COLORFF00FF, DOTLINE,LINETHICK1;
    }
    {M60:MA(CLOSE,60); POINTDOT}
    {M89:MA(CLOSE,89),LINETHICK2,COLORFF9966;}
    {//一二零日:=MA(C,120),LINETHICK1,COLOR000099;
    //一四四日:MA(C,144),LINETHICK1,COLORFF3300; //BLUE
    }
    上轨:(1+6/100)*MA(CLOSE,25), COLORBLUE,LINETHICK2;
    {M90:MA(CLOSE,90);}
    {M120:MA(CLOSE,120);}
    {M250:MA(CLOSE,250);};
    {//顶部显示}
    SBL1 := STRCAT('1地区:', DYBLOCK);
    SBL2 := ' ';{STRCAT('   2行业:', HYBLOCK);}
    SBL3 := STRCAT('   3主题投资:', EXTERNSTR(0,1));
    SBL4 := STRCAT(' ', ZDBLOCK);
    SBL41 := STRCAT(STRCAT('  4.概念: ',  GNBLOCK), STRCAT('   55.自定义:', ZDBLOCK) );
    SBL43 := STRCAT(' 5.风格:', FGBLOCK);
    {SBL4 := STRCAT(STRCAT(SBL1, SBL2), SBL3);}
    SBL5 := STRCAT(STRCAT(STRCAT(STRCAT(SBL1, SBL2), SBL4), SBL41), SBL43);
    DRAWTEXT_FIX(1, 0.0, 0.0.1, 0, SBL5),COLORFF6000;
    {底部显示}
    SBL:= STRCAT('                                ', STRCAT(STRCAT(STRCAT(HYBLOCK,DYBLOCK),GNBLOCK),ZDBLOCK) );
    {DRAWTEXT_FIX(1,0,70,0,SBL),COLORFF6000;}
    DRAWTEXT_FIX(ISLASTBAR,0,70,0,SBL3),COLORFF6000;
    总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
    {流通盘:=STRCAT(STRCAT('  流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');}
    全流通:=STRCAT('  流通比: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
    流通值:=(CAPITAL/1000000)*C;
    市值:=STRCAT(STRCAT('  流通: ',CON2STR(流通值,2)),'亿');
    股本市值:=STRCAT('市值: ',STRCAT(STRCAT(STRCAT(总股本,全流通),市值),''));
    {DRAWTEXT_FIX(ISLASTBAR,0.005,0.115,0,股本市值),COLORBLUE;}
    DRAWTEXT_FIX(流通值>100,0,0.12,0,股本市值),COLORGREEN;     {大于100亿显示绿色}
    DRAWTEXT_FIX(流通值>=200,0,0.12,0,股本市值),COLORBLUE;      {小于100亿显示蓝色}
    DRAWTEXT_FIX(流通值<=100,0,0.12,0,股本市值),COLORRED;      {小于100亿显示红色}
    Q2:=REF(O,2)>REF(C,2);{2日前的开盘价>2日前的收盘价}
    Q1:=REF(O,1)>REF(C,1) AND REF(C,1)<REF(C,2); {1日前的开盘价>1日前的收盘价 AND 1日前的收盘价<2日前的收盘价}
    YBY:=C>O AND C>REF(H,1); {目前是阳线 AND 当前价>1日前的最高价}
    YZ:=YBY AND Q1 AND Q2 AND REF(C,1)<REF(C,2); {连跌2天,今天收阳了}
    DRAWICON(YZ AND C<55 AND DYNAINFO(4)>0,L*0.95,1);
    XG:DRAWTEXT(YZ AND C<55 AND DYNAINFO(4)>0,L*0.90,'逆转');
    {强势股要突破上轨线}
    {上轨:(1+6/100)*MA(CLOSE,25), COLORBLUE,LINETHICK2;};
    {大宗交易, 大宗交易的价格超过收盘价,叫溢价,低于收盘价叫折价}
    大宗交易 := SIGNALS_USER(298, 0), NODRAW; 
    减持金额 :=  VARCAT(VAR2STR(大宗交易/10000.0 , 2),'亿'); {单位是:亿}
    {FLOAT FBILIU =  (收盘价 - 成交价) / 收盘价;}
    比率     := FRACPART(大宗交易), NODRAW; {得到小数部分,带正负符号的}
    成交价   := C - C*比率,  NODRAW; 
    {成交价格小于收盘价,0.1,折价甩卖,显示绿色}
    {DRAWTEXT(比率>0, H, 减持金额),  COLOR008000; 
    DRAWTEXT(比率>0, 成交价, '减----'),  COLOR008000; }
    DRAWTEXT(比率>=0, H*1.015, '减'),  COLOR008000; 
    DRAWTEXT(比率>=0, 成交价, 减持金额),  COLOR008000; 
    {//成交价格高于收盘价0.5,溢价,显示红色}
    DRAWTEXT(比率<0, 成交价, 减持金额),  COLORRED; 
    {//成交价格高于收盘价0.5,溢价,显示红色}
    DRAWTEXT(比率<0, 成交价, 减持金额),  COLORRED; 
    {除权后显示蝴蝶}
    {FINANCE(1)=总股本 FINANCE(7)=流通股本}
    除权条件 := ( FINANCE(1)>REF(FINANCE(1),1) ) AND (FINANCE(7)>REF(FINANCE(7), 1)  AND 流通值<=1000);
    送股数   := (FINANCE(1)/REF(FINANCE(1), 1)-1)*10;
    DRAWICON(除权条件, H, 28);
    DRAWTEXT(除权条件, L*0.96, '高转送'),  COLORRED;
    DRAWNUMBER(除权条件, L*0.95, 送股数), COLORRED;
    {跳空高开 并且 涨停}
    TJ1 := (O > REF(C, 1)) AND  (C>=REF(C,1)*1.095);
    TJ2 := VOL > 40000; {去除停牌和低成交量连板的股票;}
    DRAWICON(TJ1 AND TJ2, H*1.0618, 25);
    DRAWICON(TJ1 AND TJ2, H*1.0718, 25);




    2、九转正宗

    {九转正宗}

    流通市值:FINANCE(40)/100000000,NODRAW;
    MA5角度:ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*180/3.142,NODRAW,COLORRED;
    循环年位置:(CLOSE-LLV(CLOSE,225))/(HHV(CLOSE,225)-LLV(CLOSE,225))*100,NODRAW,COLORGREEN;
    XA_1:=AMOUNT/VOL/100;
    XA_2:=CLOSE>OPEN AND REF(CLOSE,1)>XA_1 AND CLOSE>XA_1 AND CLOSE<300;
    STICKLINE(XA_2,OPEN,CLOSE,1,0),COLORLICYAN;
    XA_3:=OPEN>CLOSE AND CLOSE<XA_1 AND XA_1>REF(CLOSE,1);
    STICKLINE(XA_3,OPEN,CLOSE,1,0),COLORRED;
    XA_4:=VOL>REF(VOL,1)*0.95 AND VOL<REF(VOL,1)*1.05;
    XA_5:=WINNER(CLOSE)-WINNER(OPEN)>=0.2 AND XA_4;
    STICKLINE(XA_5,OPEN,CLOSE,1,0),COLORBLUE;
    XA_6:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
    XA_7:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND XA_6>=4.945;
    XA_8:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND XA_6<=(-4.945);
    涨停价:IF(XA_7,REF(CLOSE,1)*1.05,REF(CLOSE,1)*1.1),NODRAW,COLORRED;
    跌停价:IF(XA_8,REF(CLOSE,1)*0.95,REF(CLOSE,1)*0.9),NODRAW,COLORGREEN;
    XA_9:=REF(CLOSE,1);
    XA_10:=CLOSE=ZTPRICE(REF(CLOSE,1),0.1);
    STICKLINE(XA_10,OPEN,CLOSE,2,0),COLORMAGENTA;
    STICKLINE(XA_10,OPEN,CLOSE,1,0),COLORMAGENTA;
    XA_11:=CLOSE=DTPRICE(REF(CLOSE,1),0.1);
    STICKLINE(XA_11,OPEN,CLOSE,2,0),COLORGREEN;
    STICKLINE(XA_11,HIGH,LOW,0,1),COLORGREEN;
    XA_12:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5);
    XA_13:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2) AND REFX(CLOSE,7)<REFX(CLOSE,3) AND REFX(CLOSE,8)<REFX(CLOSE,4);
    XA_14:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6);
    XA_15:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2) AND REFX(CLOSE,7)<REFX(CLOSE,3);
    XA_16:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7);
    XA_17:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2);
    XA_18:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8);
    XA_19:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1);
    XA_20:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9);
    XA_21:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE;
    XA_22:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10);
    XA_23:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1);
    XA_24:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11);
    XA_25:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2);
    XA_26:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11) AND REF(CLOSE,8)>REF(CLOSE,12);
    XA_27:=REFX(CLOSE,1)<REF(CLOSE,3);
    XA_28:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11) AND REF(CLOSE,8)<REF(CLOSE,12) AND REF(CLOSE,9)>REF(CLOSE,13);
    XA_29:=IF(PERIOD<4,LOW*(1-(PERIOD+1)/10*0.01),LOW*0.98);
    XA_30:=IF(PERIOD<4,HIGH*(1+(PERIOD+1)/10*0.01),HIGH*1.05);
    XA_31:=CURRBARSCOUNT-1;
    DRAWNUMBER(XA_12 AND (XA_13 OR XA_31=0 OR (XA_31=1 AND XA_27) OR (XA_31=2 AND XA_25) OR (XA_31=3 AND XA_23) OR (XA_31=4 AND XA_21) OR (XA_31=5 AND XA_19) OR (XA_31=6 AND XA_17) OR (XA_31=7 AND XA_15)),XA_29,1),COLORGREEN;
    DRAWNUMBER(XA_14 AND (XA_15 OR XA_31=0 OR (XA_31=1 AND XA_27) OR (XA_31=2 AND XA_25) OR (XA_31=3 AND XA_23) OR (XA_31=4 AND XA_21) OR (XA_31=5 AND XA_19) OR (XA_31=6 AND XA_17)),XA_29,2),COLORGREEN;
    DRAWNUMBER(XA_16 AND (XA_17 OR XA_31=0 OR (XA_31=1 AND XA_27) OR (XA_31=2 AND XA_25) OR (XA_31=3 AND XA_23) OR (XA_31=4 AND XA_21) OR (XA_31=5 AND XA_19)),XA_29,3),COLORGREEN;
    DRAWNUMBER(XA_18 AND (XA_19 OR XA_31=0 OR (XA_31=1 AND XA_27) OR (XA_31=2 AND XA_25) OR (XA_31=3 AND XA_23) OR (XA_31=4 AND XA_21)),XA_29,4),COLORGREEN;
    DRAWNUMBER(XA_20 AND (XA_21 OR XA_31=0 OR (XA_31=1 AND XA_27) OR (XA_31=2 AND XA_25) OR (XA_31=3 AND XA_23)),XA_29,5),COLORGREEN;
    DRAWNUMBER(XA_22 AND (XA_23 OR XA_31=0 OR (XA_31=1 AND XA_27) OR (XA_31=2 AND XA_25)),XA_29,6),COLORGREEN;
    DRAWNUMBER(XA_24 AND (XA_25 OR XA_31=0 OR (XA_31=1 AND XA_27)),XA_29,7),COLORGREEN;
    DRAWNUMBER(XA_26 AND (XA_27 OR XA_31<1),XA_29,8),COLORGREEN;
    DRAWNUMBER(XA_28,XA_29,9),COLORRED;
    XA_32:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5);
    XA_33:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2) AND REFX(CLOSE,7)>REFX(CLOSE,3) AND REFX(CLOSE,8)>REFX(CLOSE,4);
    XA_34:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6);
    XA_35:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2) AND REFX(CLOSE,7)>REFX(CLOSE,3);
    XA_36:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7);
    XA_37:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2);
    XA_38:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8);
    XA_39:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1);
    XA_40:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9);
    XA_41:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE;
    XA_42:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10);
    XA_43:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1);
    XA_44:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11);
    XA_45:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2);
    XA_46:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11) AND REF(CLOSE,8)<REF(CLOSE,12);
    XA_47:=REFX(CLOSE,1)>REF(CLOSE,3);
    XA_48:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11) AND REF(CLOSE,8)>REF(CLOSE,12) AND REF(CLOSE,9)<REF(CLOSE,13);
    DRAWNUMBER(XA_32 AND (XA_33 OR XA_31=0 OR (XA_31=1 AND XA_47) OR (XA_31=2 AND XA_45) OR (XA_31=3 AND XA_43) OR (XA_31=4 AND XA_41) OR (XA_31=5 AND XA_39) OR (XA_31=6 AND XA_37) OR (XA_31=7 AND XA_35)),XA_30,1),COLORMAGENTA;
    DRAWNUMBER(XA_34 AND (XA_35 OR XA_31=0 OR (XA_31=1 AND XA_47) OR (XA_31=2 AND XA_45) OR (XA_31=3 AND XA_43) OR (XA_31=4 AND XA_41) OR (XA_31=5 AND XA_39) OR (XA_31=6 AND XA_37)),XA_30,2),COLORMAGENTA;
    DRAWNUMBER(XA_36 AND (XA_37 OR XA_31=0 OR (XA_31=1 AND XA_47) OR (XA_31=2 AND XA_45) OR (XA_31=3 AND XA_43) OR (XA_31=4 AND XA_41) OR (XA_31=5 AND XA_39)),XA_30,3),COLORMAGENTA;
    DRAWNUMBER(XA_38 AND (XA_39 OR XA_31=0 OR (XA_31=1 AND XA_47) OR (XA_31=2 AND XA_45) OR (XA_31=3 AND XA_43) OR (XA_31=4 AND XA_41)),XA_30,4),COLORMAGENTA;
    DRAWNUMBER(XA_40 AND (XA_41 OR XA_31=0 OR (XA_31=1 AND XA_47) OR (XA_31=2 AND XA_45) OR (XA_31=3 AND XA_43)),XA_30,5),COLORMAGENTA;
    DRAWNUMBER(XA_42 AND (XA_43 OR XA_31=0 OR (XA_31=1 AND XA_47) OR (XA_31=2 AND XA_45)),XA_30,6),COLORMAGENTA;
    DRAWNUMBER(XA_44 AND (XA_45 OR XA_31=0 OR (XA_31=1 AND XA_47)),XA_30,7),COLORMAGENTA;
    DRAWNUMBER(XA_46 AND (XA_47 OR XA_31<1),XA_30,8),COLORMAGENTA;
    DRAWNUMBER(XA_48,XA_30,9),COLORGREEN;
    XA_49:=CONST(HHV(REF(HIGH,1),240));
    XA_50:=CONST(LLV(REF(LOW,1),240));
    XA_51:=XA_49-XA_50;
    XA_52:=LOW-XA_51*0.03;
    XA_53:=HIGH+XA_51*0.03;
    XA_54:=CLOSE>500;
    XA_55:=MAX(CLOSE,OPEN);
    XA_56:=MIN(CLOSE,OPEN);
    XA_57:=0;
    XA_58:=1;
    XA_59:=IF(XA_54,HIGH,XA_55);
    XA_60:=IF(XA_54,LOW,XA_56);
    XA_61:=IF(CLOSE>OPEN,IF(XA_58=0,LOW,XA_60),IF(XA_58=0,HIGH,XA_59));
    XA_62:=2/1000;
    XA_63:=CURRBARSCOUNT;
    XA_64:=120;
    XA_65:=XA_63<=XA_64;
    XA_66:=LOW;
    XA_67:=IF(XA_57=0,XA_66,REF(XA_57,XA_57));
    基准价:IF(XA_65,CONST(XA_67),DRAWNULL),DOTLINE,COLORRED;
    XA_68:=基准价;
    XA_69:=XA_68*XA_62;
    XA_70:=ABS(LOW-XA_68)<=XA_69;
    XA_71:=ABS(OPEN-XA_68)<=XA_69;
    XA_72:=ABS(CLOSE-XA_68)<=XA_69;
    XA_73:=ABS(HIGH-XA_68)<=XA_69;
    XA_74:=XA_70 OR XA_71 OR XA_72 OR XA_73 AND XA_65 AND XA_63!=1;
    XA_75:=COUNT(XA_74,XA_64);
    精准点个数:IF(XA_75>0,XA_75+1,0),NODRAW,COLORRED;
    DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.58188.COM '),COLORRED;
    DRAWTEXT_FIX(C>O,1,1,0,'股民学校整理'),COLORRED;



    3、安全点KDJ

    P1:=10;   {这个参数调整为7不错}

    P2:=4;
     
    80, POINTDOT, COLORGREEN, LINETHICK4;
    20, POINTDOT, COLORRED, LINETHICK4;
    0,  POINTDOT, COLORYELLOW, LINETHICK4;
     
    VAR1:=LLV(LOW,P1);
    VAR2:=HHV(HIGH,P1);
    RSV:=(CLOSE-VAR1)/(VAR2-VAR1)*100;
    K: EMA(RSV,P2),COLORWHITE;
    D: EMA(0.667*REF(K,1)+0.333*K,2), COLORYELLOW;
    J: 3*K-2*D, COLORFF00FF;
     
    EMA3:=EMA(C,2.6);
    EMA5:=EMA(C,5.1);
     
    DRAWBAND (K, RGB(255,0,0), D, RGB(0,222,0));   {//填充浅红色}
    {DRAWBAND  (K<D, D, K), COLOR66FF99;   {//填充浅绿色}
    条件1:= CROSS(K,D)  AND K<60;
    DRAWTEXT(REF(J,1)<0 AND J>=0 AND K<25, 60, '安全点现'),COLORRED;
     
     
     
    {VARC:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1); 
    VARD:=EMA(IF(C< EMA(C,250),VARC*1000,VARC*10),3); 
    火焰山:=EMA(IF(L<=LLV(L,30),VARD/2+HHV(VARD,30),0),3)/618, COLOR99FFFF, LINETHICK2; 
    }
     
     
    开心:=EMA(EMA(C,12)-EMA(C,25),2),COLORCC00CC,LINETHICK2;
    短线交易:=EMA(开心,6),COLORD4FF7F,LINETHICK2;
    系统:=(短线交易<(MA(C,3)*0.618/C))*短线交易 ,LINETHICK0;
    WWW:=EMA(EMA(C,12)-EMA(C,25),2),COLORYELLOW,LINETHICK0;
    XDKXGS:=EMA(开心,6),COLORYELLOW,LINETHICK0;
    CN:=(短线交易<(MA(C,3)*0.618/C))*短线交易,COLORYELLOW ,LINETHICK0;
    启动条件:=(系统 OR 短线交易<(MA(C,3)*0.618/C)) AND CROSS(开心 ,短线交易 ) AND V>REF( MA(V,5),1)*1.1 AND C>MA(C,125) AND C>REF(C,1)*1.02;
    DRAWTEXT(启动条件 ,35,'↑通吃启动'),COLORRED;
     
     
     
     
    VARA:=REF(LOW,1);
    VARB:=SMA(ABS(LOW-VARA),3,1)/SMA(MAX(LOW-VARA,0),3,1)*100;
    VARC1:=EMA(IF(CLOSE*1.3,VARB*10,VARB/10),3);
    VARD1:=LLV(LOW,30);
    VARE:=HHV(VARC1,30);
    VARF:=IF(MA(CLOSE,58),1,0);
    VARG:=EMA(IF(LOW<=VARD1,(VARC1+VARE*2)/2,0),3)/618*VARF;
    VARH:=IF(VARG>28,28,VARG);
    {黄柱吸筹区:STICKLINE(VARH>-120,0,VARH,6,0),COLOR0FFFFF;}
    RSV1:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
    K1:=SMA(RSV1,3,1);
    D11:=SMA(K1,3,1);
    J11:=3*K1-2*D11;
    X:=LLV(J11,2)=LLV(J11,8);
    DRAWTEXT(BARSLAST(CROSS(J11,3))<6 AND 条件1,51,'跟庄'),COLORBLUE;
     
     
    缺口:=DRAWLINE(REF(L,1)>H AND C<REF(L,1),H,REF(REF(L,1)>H AND C<REF(L,1),1),REF(H,1),1);
    突破:CROSS(C,缺口) AND (C-REF(C,1))/REF(C,1)*100>5 AND DYNAINFO(4)>0, COLORBLUE;
     
    {一定时跌,涨的不算,上涨的最高点到当前的周期数据 肯定大于 最小值到当前的周期数 }
    N:=100;
    下跌   := HHVBARS(HIGH, N) > LLVBARS(LOW, 6);
    去停牌 := DYNAINFO(8)>0;
    跌幅   :=  (HHV(HIGH, N) - LLV(LOW, 6)) / HHV(HIGH, N) ;
    跌幅100 :  跌幅 * (下跌) * (去停牌) * 100;
    CB财经网:致力于为用户打造一个正规可靠的股票配资、炒股经验分享交流平台。

    本文标题:「收盘价」通达信源码:十战七胜主图,九转正宗,安全点KDJ 地址: http://www.lagzc.com/gppz/12345.html

    免责声明:部分文章信息来源于网络以及网友投稿,本网站只负责对文章进行整理、排版、编辑,是出于传递 更多信息之目的,并不意味着赞同其观点或证实其内容的真实性,如本站文章和转稿涉及版权等问题,请作者在及时联系本站,我们会尽快和您对接处理。
    上证指数大盘实时行情
    十大配资平台
    名称 是否实盘 网址
    中天创投 访问
    京海策略 访问
    简配资 访问
    久联优配 访问
    杨方配资 待验证 访问
    鸿牛配资 待验证 访问
    申捷策略 待验证 访问
    涵星配资 待验证 访问
    简配资 待验证 访问
    金桥大通 待验证 访问
    广告

    网站首页 - 股票配资 - 期货配资 - 外汇配资 - 股票行情 - 正规配资平台 - 配资资讯 - 配资技巧 - 配资公司 - 投资理财 - 用户须知

    备案号:粤ICP备12525258029120号 技术支持:CB财经网

    Copyright © 2002-2020 CB123456财经网新闻资讯网 版权所有t>