网站地图
  • 股票配资
  • 期货配资
  • 外汇配资
  • 股票行情
  • 正规配资平台
  • 配资资讯
  • 配资技巧
  • 配资公司
  • 投资理财
  • 用户须知
  • 「中线」同花顺源码:千载难逢出手大抄底,买卖提醒,▼底1PRO 底部买入

    文章来源:CB财经网 发布时间: 2020-05-28 16:18:59作者:文轩阅读()
    1、千载难逢出手大抄底,抄底类公式

    N:=9;
    M:=2;
    VAR2:=REF(LOW,1);
    VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
    VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
    RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
    RSV2:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*100;
    VAR5:=LLV(LOW,30);
    VAR6:=HHV(VAR4,30);
    短线:SMA(SMA(RSV1,3,1),3,1)+3*STD(CLOSE,21),COLOR00FF00;
    中线:SMA(RSV2,5,1)+2*STD(CLOSE,37),colorred;
    VAR7:=IF(MA(CLOSE,58),1,0);
    VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
    RSV3:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
    VAR9:=IF(VAR8>100,100,VAR8);
    长线:SMA(RSV3,5,1),coloryellow;
    看底:STICKLINE(中线<15,中线,15,6,0),COLORF00FF0;
    STICKLINE(VAR9>-150,0,VAR9,3,0), , COLORFF00FF;
    底部吸筹指标:(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100, , COLOR00FF00;
    STICKLINE(CROSS(底部吸筹指标,-24),100,0,6,0), , COLORFFFFFF;
    黄金坑:STICKLINE(短线<20 AND 中线<20 AND 长线<20,
    MAX(长线,MAX(短线,中线)),20,8,0),COLOR00CCFF;
    看顶:STICKLINE(中线>80,80,中线,6,0),COLORFFF000;
    先知: (CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100, , COLORFF00FF;
    可能放量拉升: IF(CROSS(底部吸筹指标,-24),1,0), , COLORFFFFFF;
    短线获利:STICKLINE(REF("KDJ.J",1)<0 AND "KDJ.J">0,60,0,2,0),COLOR0000FF;
    DRAWICON(CROSS(长线,15),中线,1);
    DRAWTEXT(LONGCROSS(中线,20,15),20,'追涨');
    VARK1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
    VARK2:=REVERSE(VARK1);
    VARK3:=SMA(VARK1,3,1);
    波段王:=SMA(VARK3,3,1), , colorred,LINETHICK2;
    波段鬼:=SMA(波段王,2.5,1),coloryellow,LINETHICK2;
    趋势线: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,
    27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,
    27)-LLV(LOW,27))*100,5,1),3,1), ,COLORFF6666,LINETHICK2;
    RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
    DRAWTEXT(CROSS(短线,长线)AND 长线<18 AND 长线>REF(长线,
    1)OR CROSS(长线,5),20,'千载难逢');
    K1:=SMA(RSV9,3,1);
    DK1:=K1-REF(K1,1),COLORSTICK;
    粘合星:DRAWTEXT(ABS(中线-长线)<2 AND 中线>REF(中线,1),中线,'*');
    出手就赢:IF(DK1>7 AND REF(DK1,1)<0 AND (DK1-REF(DK1,
    1))>9,50,0), STICK,coloryellow;DRAWICON(出手就赢>0,50 ,1);
    中线2:=-100*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40));
    买点准备:IF(趋势线<=10,0,10), COLORFF9933,LINETHICK3;
    底:DRAWTEXT(CROSS(中线2,-90) AND (长线<中线 AND 长线>REF(长线,
    1)OR 短线<20 AND 中线<20 AND 长线<20),长线,'底'),COLORFF00FF;
    STICKLINE( CROSS(趋势线,10),0,73,6,0), COLOR3366FF,;
    IF(COUNT(CROSS(中线2,-90),12)=3,30,5);
    IF(COUNT(CROSS(-5,中线2),12)=3 OR COUNT(CROSS(-15,中线2),6)=3,70,100);
    DRAWTEXT(IF(CROSS(趋势线,10),100,0),68,'抄底'),colorwhite ;



    2、买卖提醒

    M:=17;//
    P:=2;
    N:=5;
    大盘指数:INDEXC,NODRAW,colorlimagenta ;
    C3:=REF(C,1);
    涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
    STICKLINE(涨停,OPEN,CLOSE,2.5,0),coloryellow;
    跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
    STICKLINE(跌停,OPEN,CLOSE,2.5,0),colorblue;
    EMA5:EMA(C,5),NODRAW;
    操盘:=EMA(C,17);
    KDJ_K:="KDJ.K"(9,3,3);KDJ_D:="KDJ.D"(9,3,3);KDJ_J:="KDJ.J"(9,3,3);
    买1:=CROSS(KDJ_J,0) OR (CROSS(KDJ_J,KDJ_K) AND KDJ_D<26);
    买2:=CROSS("RSI.RSI1"(6,2,2),20) OR CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
    买3:=CROSS("MACD.DIF","MACD.DEA") OR CROSS("MACD.MACD",0);
    买0:=买1+买2+买3;
    DRAWICON(买0>1,L*0.98,16);
    X6:=REF(CLOSE,1);
    X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
    X8:=CROSS(79,X7);
    X9:=FILTER(X8,4);
    DRAWTEXT(X9,(HIGH * 1.02),'●出货'),COLOR9000F5;
    上升压力: 操盘 + P*STD(CLOSE,M),COLOR0099FF,LINETHICK2;
    下跌支撑: 操盘 - P*STD(CLOSE,M),colormagenta,LINETHICK2;
    DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIF,9);
    MACD1:=(DIF-DEA)*2,COLORSTICK;
    A:=MA(CLOSE,5);
    B:=MA(CLOSE,20);
    TYP:=(HIGH+LOW+CLOSE)/3;
    CCI:=(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84));
    BB:=BETWEEN(REF(CLOSE,1),A,B);
    DRAWTEXT(CLOSE>A AND A>B AND B>REF(B,1) AND CROSS(CCI,100) AND MACD1>0 AND REF(MACD1,1)>0,B,'追'),coloryellow;
    CBFB:=MA(C,2);
    JL:=IF(C>CBFB,V,0);
    CL:=IF(C<CBFB,V,0);
    JLH:=SUM(JL,4);
    CLH:=SUM(CL,4);
    LHB:=CLH/JLH;
    TJ1:=IF(HHV(LHB,5)>4 AND CROSS(2,LHB) AND C>=O,1,0);
    DRAWICON(TJ1,L*0.96,9);
    Z:=MA(C,120);
    VAR3:=(MA(C,5)-Z)/Z;
    VAR4:=MA((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100,3);
    VAR5:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,120)/MA(VOL,120)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100);
    D1:DRAWTEXT(CLOSE>Z AND REF(VAR4,1)<30 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2) ,LOW ,'★B'),colorred;
    D2:DRAWTEXT(REF(VAR5,1)<5 AND VAR5>REF(VAR5,1) AND REF(VAR5,1)<REF(VAR5,2) AND VAR3<-0.3,LOW ,'★B'),colorgreen;
    D3:DRAWTEXT(CROSS(VAR4,5) AND VAR3<-0.4,LOW ,'★B'),colorblue;
    Y:=MA(C,120);
    VAR6:=(MA(C,5)-Y)/Y;
    VAR7:=MA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,3);
    VAR8:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,120)/MA(VOL,120)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100);
    D4:DRAWTEXT(CLOSE<Y AND Y<REF(Y,1) AND REF(VAR7,1)>80 AND VAR7<REF(VAR7,1) AND REF(VAR7,1)>REF(VAR7,2),HIGH,'★S'),coloryellow;
    D5:DRAWTEXT(CROSS(90,VAR7) AND VAR8>0.2,HIGH,'★S'),colorgreen;
    D6:DRAWTEXT(CROSS(95,VAR7) AND VAR6>0.5,HIGH ,'★S'),colorred;
    MAA5:=MA(C,5),COLORFF00FF,LINETHICK2;
    MAA10:=MA(C,10);
    MAA30:=MA(C,30),colorred;
    KS:=IF(MAA10>MAA30,MAA10,MAA30),colorblue;
    A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
    A4:=SMA(A3,3,1);
    A5:=SMA(A4,3,1);
    A6:=3*A4-2*A5;
    A7:=C-REF(C,1);
    A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
    买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
    DRAWTEXT(FILTER(买=1,5),LOW-0.05,'↖买进'),coloryellow;
    STICKLINE(买,OPEN,CLOSE,2,0),coloryellow;
    X1:=(C+L+H)/3;
    BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
    EMA8:=EMA(C,8);
    DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
    EMA8,'∠45升'),colorwhite;
    A01:=MA(CLOSE, 28);
    A02:=MA(CLOSE, 66);
    A03:=AMOUNT / VOL / 100.000;
    A04:=SUMBARS(VOL,CAPITAL * 1.618);
    A05:=IF((A04 > 100.000), 1.033,IF(((A04 <= 100.000) AND (A04 > 33.000)), 1.039, 1.05));
    运作成本:MA(A03, 10),NODRAW;
    中线成本:EMA(A03, 34) * A05,NODRAW;
    总体成本:DMA(中线成本,VOL / CAPITAL),NODRAW;
    VAR12:=(2*CLOSE+HIGH+LOW)/4;
    VAR13:=IF(YEAR>=2099 AND MONTH>2,0,1);
    VAR14:=LLV(LOW,5); VAR15:=HHV(HIGH,4);
    散户:=EMA((VAR12-VAR14)/(VAR15-VAR14)*100,4)*VAR13;
    庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR13;
    DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),colorlired;
    DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),colorgreen;




    3、▼底1PRO 底部买入

    底部买入。▼底1 + ▼底1P。
    手优先于笑脸,笑脸出现可能买入会晚点,但也不是没有机会。
    3者一起  >  手+(紧跟)箭头  >  笑脸+(紧跟)箭头,时买入。( CB财经 股票学院: http://58188.com )
    不能完全相信指标,要看大盘、股性。随心而动,随刃而行。
    【猛涨龙头股,最近第一次最高的黑马线跌至15%可以再入。】
    【部分强势股,第二波最高的黑马线跌至1%可以再入。】----【最好别试,有点危险。】

     

    IF(PERIODNAME<>"日线")

    {
    统计:"该指标只在日线周期下有效。";
    RETURN;
    }
    //大单净量
    r:=((ZDMR[-1]+BDMR[-1])-(ZDMC[-1]+BDMC[-1]))/SHGZG*100;
    //相对强弱
    LC := REF(CLOSE,1);//前一日收盘价;
    RSI$1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
    RSI$2:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
    RSI$3:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
    相对强弱:=0.5*RSI$1+0.31*RSI$2+0.19*RSI$3;
    wave$1:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),3,1);
    wave$2:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),5,1);
    wave$3:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),8,1);
    短线波段:=0.5*wave$1+0.31*wave$2+0.19*wave$3;
    机会区:20,POINTDOT,colorred;
    风险区:80,POINTDOT,colorgreen;
    风险系数:0.5*相对强弱+0.5*短线波段,colorliblue;
    //买入条件;
    CD1:=IF(风险系数<20 AND CLOSE>OPEN AND r>0,1,0);//波段小于20,股价翻红;
    CD2:=IF(风险系数<20 AND LOW>=REF(LOW,1) AND CLOSE>LOW AND r>0,1,0);//波段小于20,股价未翻红,但未创新低;
    CD3:=IF(REF(风险系数,1)<20 AND 风险系数>REF(风险系数,1),1,0);//前一日波段小于20,今日转向;
    SIGNALBUY=(CD1=1 OR CD2=1 OR CD3=1);
    X=(SIGNALBUY AND COUNT(SIGNALBUY,3)=1);
    DRAWICON(X,机会区,11);
    //buy 2;
    机会区xx:25.99,POINTDOT,colorwhite;//之前24,改为25.99
    CDxx1:=IF(风险系数<25.99 AND 风险系数>=20 AND CLOSE>OPEN AND r>0,1,0);//波段小于20,股价翻红;
    CDxx2:=IF(风险系数<25.99 AND 风险系数>=20 AND LOW>=REF(LOW,1) AND CLOSE>LOW AND r>0,1,0);//波段小于20,股价未翻红,但未创新低;
    CDxx3:=IF(REF(风险系数,1)<25.99 AND REF(风险系数,1)>=20 AND 风险系数>REF(风险系数,1),1,0);//前一日波段小于20,今日转向;
    SIGNALBUYxx=(CDxx1=1 OR CDxx2=1 OR CDxx3=1);
    Xxx=(SIGNALBUYxx AND COUNT(SIGNALBUYxx,3)=1);
    DRAWICON(Xxx,机会区xx,5);
    //----------part222222222--------;
    VAR3:=LLV(HIGH,240);
    VAR4:=100*(CLOSE-VAR3)/VAR3;
    VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
    VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
    VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
    VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
    VARA:=BARSCOUNT(CLOSE);
    VARB:=VAR8<20 AND VAR9<23 AND VARA>35;
    VARC:=VARB AND COUNT(VARB,1)=1;
    VARD:=EMA(CLOSE,21)-EMA(CLOSE,8);
    VARE:=EMA(VARD,5);
    VARF:=TROUGHBARS(3,6,1)<4 AND CROSS(VARD,VARE);
    VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
    VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
    VAR12:=ZIG(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
    VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
    VAR14:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
    VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
    VAR16:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
    VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
    VAR18:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
    VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
    VAR1A:=EMA(VAR19,100);
    VAR1B:=2*(VAR19-VAR1A);
    VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);
    VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
    VAR1E:=EMA(VAR1D*0.97,3);
    VAR1F:=(HIGH+LOW+CLOSE)/3;
    VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV(VAR1F,14));
    VAR21:=CROSS(VAR1E,LOW);
    选股买点:VAR10,coloryellow;
    组合买:(VAR11+VAR13+VAR15+VAR17),colorred;
    组合卖:(VAR12+VAR14+VAR16+VAR18),colorgreen;
    黑马线:IF(VAR1B>0.1,VAR1C,0)*1;
    黑马信号介入点:选股买点 AND VARF AND VARC AND VAR21 AND VAR4<0 AND VAR5<2 AND VAR6=0,colorliblue;
    DRAWTEXT(VAR13,0.6,'●'),colorred;
    DRAWICON(组合买,组合买,1);
    DRAWICON(组合卖,组合卖,9);
    DRAWTEXT(黑马信号介入点>0,4.5,'●我的黑马介入点'),colorred;
    DRAWICON(选股买点>0,4.2,1);
    DRAWTEXT(选股买点 AND VARF AND VARC,2.8,' 30%下单莫错过!'),colormagenta;
    DRAWTEXT(VAR18,3,'空仓'),colorgreen;
    DRAWTEXT(VAR20<-110 AND 选股买点>0,2,'选股买点'),coloryellow;
    DRAWTEXT(VAR17,1.3,'发现黑马'),colorliblue;
    DRAWTEXT(选股买点 AND VAR20<-100 AND VARF AND VARC>0,4.1,'★组合5分钟线选股思路获利5%以上'),colorred
    CB财经网:致力于为用户打造一个正规可靠的股票配资、炒股经验分享交流平台。

    本文标题:「中线」同花顺源码:千载难逢出手大抄底,买卖提醒,▼底1PRO 底部买入 地址: http://www.lagzc.com/gppz/12356.html

    免责声明:部分文章信息来源于网络以及网友投稿,本网站只负责对文章进行整理、排版、编辑,是出于传递 更多信息之目的,并不意味着赞同其观点或证实其内容的真实性,如本站文章和转稿涉及版权等问题,请作者在及时联系本站,我们会尽快和您对接处理。
    上证指数大盘实时行情
    十大配资平台
    名称 是否实盘 网址
    中天创投 访问
    京海策略 访问
    简配资 访问
    久联优配 访问
    杨方配资 待验证 访问
    鸿牛配资 待验证 访问
    申捷策略 待验证 访问
    涵星配资 待验证 访问
    简配资 待验证 访问
    金桥大通 待验证 访问
    广告

    网站首页 - 股票配资 - 期货配资 - 外汇配资 - 股票行情 - 正规配资平台 - 配资资讯 - 配资技巧 - 配资公司 - 投资理财 - 用户须知

    备案号:粤ICP备12525258029120号 技术支持:CB财经网

    Copyright © 2002-2020 CB123456财经网新闻资讯网 版权所有t>